VirtualBox

Opened 9 months ago

Closed 9 months ago

Last modified 8 months ago

#21692 closed defect (duplicate)

Vbox Guest Additions fail to install- Centos Stream 8 kernel 4.18.0-492.el8.x86_64

Reported by: TziG Owned by:
Component: guest additions Version: VirtualBox-7.0.8
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Guest Additions fail to install at centos 8 vm. Attached you will find the logs.

Attachments (1)

vboxadd-setup-log.txt (2.0 KB ) - added by TziG 9 months ago.

Download all attachments as: .zip

Change History (4)

by TziG, 9 months ago

Attachment: vboxadd-setup-log.txt added

comment:1 by TziG, 9 months ago

Guest Additions fail to install at centos 8 vm. Attached you will find the logs.

Building the main Guest Additions 7.0.9 module for kernel 4.18.0-492.el8.x86_64.
Building the shared folder support module.
Building the graphics driver module.
Error building the module.  Build output follows.
make V=1 CONFIG_MODULE_SIG= CONFIG_MODULE_SIG_ALL= -C /lib/modules/4.18.0-492.e$
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (       $
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are$
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it$
echo >&2 ;                                                      \
/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f ./scripts/Makefile.build obj=/tmp/vbox.0
(cat /dev/null;   echo kernel//tmp/vbox.0/vboxvideo.ko;) > /tmp/vbox.0/modules.$
  gcc -Wp,-MD,/tmp/vbox.0/.hgsmi_base.o.d  -nostdinc -isystem /usr/lib/gcc/x86_$
In file included from /tmp/vbox.0/hgsmi_base.c:27:
/tmp/vbox.0/vbox_drv.h:382:25: error: field ‘base’ has incomplete type
  struct drm_framebuffer base;
echo >&2 ;                                                      \
/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f ./scripts/Makefile.build obj=/tmp/vbox.0
(cat /dev/null;   echo kernel//tmp/vbox.0/vboxvideo.ko;) > /tmp/vbox.0/modules.order
  gcc -Wp,-MD,/tmp/vbox.0/.hgsmi_base.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-redhat-linux/8/include -I./arch/x$
In file included from /tmp/vbox.0/hgsmi_base.c:27:
/tmp/vbox.0/vbox_drv.h:382:25: error: field ‘base’ has incomplete type
  struct drm_framebuffer base;
                         ^~~~
make[2]: *** [scripts/Makefile.build:318: /tmp/vbox.0/hgsmi_base.o] Error 1
make[1]: *** [Makefile:1616: _module_/tmp/vbox.0] Error 2
make: *** [/tmp/vbox.0/Makefile-footer.gmk:133: vboxvideo] Error 2

comment:2 by galitsyn, 9 months ago

Resolution: duplicate
Status: newclosed

This ticket is a duplicate of #21690. Fix is now available with the test builds.

comment:3 by Boxy, 8 months ago

As my search for "drm_framebuffer" and/or "vbox_drv.h" lead me to this ticket, just to append: had the same issue in RHEL 8.6 for those kernels:
4.18.0-477.13.1.el8_8.x86_64
4.18.0-477.15.1.el8_8.x86_64

I did as #21690 advises and installed VBoxGuestAdditions_6.1.45-158226 today with success: "/sbin/rcvboxadd quicksetup all" works without errors.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use