VirtualBox

Ticket #212 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Guest PAE not supported/Mac OSX won't install/Ubuntu Server fails to boot after install -> fixed in 1.6.0

Reported by: tolmi Owned by:
Priority: critical Component: other
Version: VirtualBox 1.3.8 Keywords: assertion failed
Cc: Guest type: other
Host type: other

Description

Host: Ubuntu Edgy on Intel Core 2 Duo
Guest: CentOS 5 beta 1 (RedHat EL5 clone)

Log follows:


Log created: 2007-03-20T00:08:15.453613000Z
Executable: /opt/VirtualBox-1.3.8/VirtualBox
Arg[0]: /opt/VirtualBox-1.3.8/VirtualBox
Arg[1]: -startvm
Arg[2]: 711f8661-079e-4892-9b48-d5aea94c1ab3


!!Assertion Failed!!
Expression: <NULL>
Location : /home/vbox/vbox-1.3/src/VBox/VMM/VMMAll/PGMAllGst.h(502) int pgmR3GstPAEMonitorCR3(VM*, RTGCPHYS)

Change History

comment:1 Changed 7 years ago by sandervl73

It's a known restriction: guest PAE is not supported. We will implement this in the future.

comment:2 Changed 7 years ago by sandervl73

  • Priority changed from blocker to major

comment:3 Changed 7 years ago by frank

Try to use a different guest kernel.

comment:4 Changed 7 years ago by sandervl73

  • Summary changed from Assertion failed on PGMAllGst.h(502) to Guest PAE not supported

comment:5 Changed 7 years ago by sandervl73

  • Summary changed from Guest PAE not supported to Guest PAE not supported/Mac OSX won't install

comment:6 Changed 7 years ago by sandervl73

  • Summary changed from Guest PAE not supported/Mac OSX won't install to Guest PAE not supported/Mac OSX won't install/Ubuntu Server fails to boot after install

comment:7 Changed 7 years ago by sandervl73

  • Priority changed from major to critical

comment:8 Changed 7 years ago by sandervl73

Same with OpenSUSE 10.3 beta apparently.

comment:9 Changed 7 years ago by sandervl73

See duplicate defect 656,

comment:10 Changed 7 years ago by Technologov

Good news: openSUSE 10.3 final installs "default" kernel, instead of PAE kernel, so this bug will NOT affect openSUSE 10.3 guests.

-Technologov

comment:11 Changed 6 years ago by snearch

Ubuntu Server 7.10 on VirtualBox 1.5.2 on Windows XP Prof. SP2 gives

"PANIC: CPU too old for this kernel."

a few seconds after rebooting.

comment:12 Changed 6 years ago by jasutton

anyone have an update on when this might be fixed?

comment:13 Changed 6 years ago by RavenMokel

Since i want to use VirtualBox to try out some Ubuntu Server variants (or other distributions using kernels which require PAE), i'm also very interested in an ETA of when this might be fixed.

-David

comment:14 Changed 6 years ago by RavenMokel

Oh, and all Debian/Ubuntu Xen-enabled kernels also require PAE. A Xen system was also something i wanted to try out using VirtualBox... looks like i either have to wait, compile my own xen kernel (without PAE) or try something completely different to try out xen.

comment:15 Changed 6 years ago by lsof

This isn't a VirtualBox bug.

Ubuntu is booting from a non-PAE kernel, then installing a PAE kernel on a box without testing it. The Ubuntu (and other) installers are at fault, not VirtualBox.

comment:16 Changed 6 years ago by jasutton

All Intel CPUs from the Pentium Pro onward (or the K6-2 and onward in the case of AMD) support PAE. Is it so unreasonable that the Ubuntu installer assumes that it is supported?

I'm not quite sure why implementing PAE support is such a problem. I wouldn't mind trying to implement it myself, if someone would point me in the right direction.

comment:17 Changed 6 years ago by frank

A program should respect the features which the CPUID instruction delivers. As VBox guests don't see the PAE feature even on PAE CPUs they should not assume that PAE is available.

Apart from this nobody said that implementing the PAE mode is very difficult. The problem is that there are a plenty of features and bugs which are not difficult to implement or to fix respectively. We will implement this mode but we cannot promise any ETA.

comment:18 Changed 6 years ago by furiousangel

In ubuntu.

I was able to install a working kernel by booting from the server install CD, launching a recovery shell, and running

apt-get install linux-generic

When booting, press ESC to enter the GRUB boot menu and select the -generic kernel

if you want you can edit /boot/grub/menu.lst and make this the default kernel.

you can also compile the kernel without PAE. good luck.

comment:19 Changed 6 years ago by sandervl73

  • Summary changed from Guest PAE not supported/Mac OSX won't install/Ubuntu Server fails to boot after install to Guest PAE not supported/Mac OSX won't install/Ubuntu Server fails to boot after install -> fixed in 1.6.0

Supported in SVN and the upcoming 1.6.

comment:20 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:21 Changed 6 years ago by singh.gurjeet

  • Status changed from closed to reopened
  • Resolution fixed deleted

This bug seems to have resurfaced!!! I am using version 1.6.4, and Ubuntu from ubuntu-8.04.1-server-i386.iso CD image.

I have created this VM to use only 64MB of RAM.

The exact message is:

Starting up ...

This kernel requires the following features not present on the CPU:

0:6

Unable to boot - please use a kernel appropriate for your CPU.

Let me know if I can provide any more info.

Going to try the alternative approach mentioned above.

comment:22 Changed 6 years ago by frank

Please could you

  • check with 1.6.6 and
  • attach the VBox.log file of that session?

comment:23 Changed 6 years ago by singh.gurjeet

I am sorry... I just noticed on anther website ( http://tombuntu.com/index.php/2007/09/05/making-ubuntu-server-work-in-virtualbox/) that the PAE support is "experimental" and then remembered having seen such an option somewhere in the GUI! (I have been a VBox user for a LoooNG time)

So I restarted the VM with the PAE/NX in General>Advanced tab. And it is working now.

Thanks for a quick response, and thumbs up for a great work you guys are doing.

Best regards, Gurjeet Singh

comment:24 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use