VirtualBox

Ticket #2118 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

OpenSolaris guest hangs at boot if VT-x enabled in 2.0.0

Reported by: pablomh Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.0.0 Keywords: VT-x, 64 bit, opensolaris
Cc: Guest type: Solaris
Host type: Windows

Description

Hi:

In a dual Intel Xeon E5410 machine (64 bit, VT-x capable), running Windows XP Professional x64 Edition, if I try to boot OpenSolaris 2008.05 snv_96 with the VT-x option active (only way I know to boot it in 64 bits), the boot hangs and can't continue. If I boot with the rest of options (ACPI, IO APIC, PAE/NX), it boots ok.

Attachments

VBox.log Download (32.0 KB) - added by pablomh 6 years ago.
VBox.log.1 Download (146.6 KB) - added by pablomh 6 years ago.
VBox.2.log Download (138.4 KB) - added by damidalla 6 years ago.
Log from an openSolaris 2008.05 guest on an Ubuntu 8.04 amd64 host

Change History

Changed 6 years ago by pablomh

Changed 6 years ago by pablomh

comment:1 Changed 6 years ago by pablomh

Please, discard VBox.log added, as it's imcomplete and from a running boot (without VT-x).

comment:2 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

Without the IO-APIC it won't work. ACPI might be required as well. See the manual 1.6.

comment:3 Changed 6 years ago by pablomh

  • Status changed from closed to reopened
  • Resolution invalid deleted

When I said "doesn't boot with the VT-x option active", I mean to say "doesnt' boot with ACPI, IO APIC, PAE/NX AND VT-x". Sorry for the bad wording :(

Changed 6 years ago by damidalla

Log from an openSolaris 2008.05 guest on an Ubuntu 8.04 amd64 host

comment:4 Changed 6 years ago by damidalla

Same here on a Linux host using openSolaris 2008.05. Host: Ubuntu 8.04 amd64 (Linux 2.6.24-21-generic kernel) Guest: openSolaris 2008.05 64bit Does not work with nor without IO-APIC, but it does work without VT-x (32bit)

comment:5 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Try again with 2.0.4 and attach a new log please. Reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use