VirtualBox

Opened 17 months ago

Closed 16 months ago

Last modified 11 days ago

#21125 closed defect (fixed)

RawDisk is creating an invalid .vmdk file => fixed in svn/7.0.x x>2

Reported by: granada29 Owned by: paulson
Component: virtual disk Version: VirtualBox 7.0.0
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

Previously discussed in https://forums.virtualbox.org/viewtopic.php?f=15&t=106934

VirtualBox 6.1.x creates a working .vmdk for this disk.

Is it possible that the disk sector size of 512Bytes is causing problems?

VBoxManage list hostdrives
Drive:       /dev/disk7
Model:       "ST2000DM 006-2DM164"
UUID:        b79360f1-e7c7-4194-b6a5-421662d648e7
Size:        1.8TiB
Sector Size: 512 bytes
Scheme:      GPT
Partitions:
##  Type       Uuid                                   Size      Start   Active Name
 1  EFI        6d60184c-7cd2-4c8f-8cae-4cc11b4614d3  200.0MiB   20.0KiB  off   EFI System Partition
 2  AppleAPFS  deb68258-920f-43fc-a62b-baba4f4eca06  279.3GiB  200.0MiB  off   
 3  LinuxData  b9b1aad8-088c-46e4-a60f-2add43cb5a5f    1.5TiB  279.5GiB  off   
 4  LinuxSwap  66701cbd-503f-4792-9b96-0e35f28e9dfd   29.8GiB    1.7TiB  off
12:02:51.516 /usr/local/bin/VBoxManage createmedium disk --filename /Volumes/VirtualBox/Virtualbox/Linux/LinuxRawPartition/LinuxRawPartition.vmdk --format=VMDK --variant RawDisk --property RawDrive=/dev/disk7 --property Partitions=1,3,4
12:02:51.825 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
12:02:51.825 Medium created. UUID: 5f68b7c7-51ae-41ca-9364-4b7bc051365d
# Disk DescriptorFile
version=1
CID=cca3f05b
parentCID=ffffffff
createType="partitionedDevice"

# Extent description
RW 1 FLAT "LinuxRawPartition-pt.vmdk" 0
RW 39 FLAT "LinuxRawPartition-pt.vmdk" 1
RW 409600 FLAT "/dev/disk7s1" 0
RW 585937496 ZERO 
RW 3258181984 FLAT "/dev/disk7s3" 0
RW 62500008 FLAT "/dev/disk7s4" 0
RW 36028793111934840 ZERO 

# The disk Data Base 
#DDB

ddb.virtualHWVersion = "4"
ddb.adapterType="ide"
ddb.uuid.image="0beb4189-4182-48e6-9fe2-4f999c8eb860"
ddb.uuid.parent="00000000-0000-0000-0000-000000000000"
ddb.uuid.modification="00000000-0000-0000-0000-000000000000"
ddb.uuid.parentmodification="00000000-0000-0000-0000-000000000000"

Attachments (1)

VBox.log.zip (34.5 KB ) - added by granada29 17 months ago.

Download all attachments as: .zip

Change History (9)

by granada29, 17 months ago

Attachment: VBox.log.zip added

comment:1 by fth0, 17 months ago

In the forum thread, the VMDK file had the following obviously wrong geometry settings (missing in the Description above):

ddb.geometry.cylinders="1"
ddb.geometry.heads="16"
ddb.geometry.sectors="63"

Since the physical disk is larger than 8 GB, ddb.geometry.cylinders should be "16383". Additionally, the last extent specification is probably much too large (~18,000 TB ;)).

comment:2 by granada29, 17 months ago

Similar issues have been reported when creating a raw disk vmdk with 'VBoxManage createmedium' on Linux.

Discussion at https://forums.virtualbox.org/viewtopic.php?f=7&t=107476

comment:3 by paulson, 17 months ago

Owner: set to paulson
Status: newassigned

Thanks for the report. The implementation of the functionality provided by 'VBoxManage createmedium disk --Variant Rawdisk ...' in VirtualBox 7.0.0 is incomplete as a small but key detail was overlooked. The root cause of this issue is known and a fix is in progress.

comment:5 by granada29, 16 months ago

Testing with VirtualBox 7.0.3 is successful for both full disk and partitioned VMDKs.

comment:6 by galitsyn, 16 months ago

Resolution: fixed
Status: assignedclosed

VirtualBox 7.0.4 was just released and available for download at https://www.virtualbox.org/wiki/Downloads. This issue should be fixed in this version.

comment:7 by paulson, 16 months ago

Summary: RawDisk is creating an invalid .vmdk fileRawDisk is creating an invalid .vmdk file => fixed in svn/7.0.x x>2

comment:8 by liar777, 11 days ago

Hi,

I'm using:

$ VBoxManage --version
7.0.14r161095

And problem was still there... (Trying to access /dev/sdb , a USB thumbdrive in my case) until I started:

qemu-system-x86_64 -m 2048 /dev/sdb

and re-ran the VBox command while qemu was running, and then it worked! WTF!?!

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use