VirtualBox

Opened 2 years ago

Closed 21 months ago

#21030 closed defect (fixed)

VirtualBox VM 6.1.36 r152435 Application Error

Reported by: Wilfried Doberstein Owned by:
Component: VM control Version: VirtualBox 6.1.36
Keywords: Application Error read Storage Cc:
Guest type: Windows Host type: Windows

Description

6.1.34 works fine, but after updating to 6.1.36, I get Application Error when starting the Windows Client. Windows Host 22H2 (22621.232) Windows Guest 23H2 Please see attached Files

Attachments (12)

Screenshot.jpg (18.9 KB ) - added by Wilfried Doberstein 2 years ago.
Screenshot
VBox.log (119.3 KB ) - added by Wilfried Doberstein 2 years ago.
Logfile
Windows 11 Pro 23H2 REDUZIERT.vbox (9.3 KB ) - added by Wilfried Doberstein 2 years ago.
MSIf0ae.LOG (27.1 KB ) - added by Wilfried Doberstein 2 years ago.
MS-Config.jpg (190.8 KB ) - added by Wilfried Doberstein 2 years ago.
MSI90822.LOG (26.1 KB ) - added by Wilfried Doberstein 2 years ago.
USB-Controller 3.0.jpg (320.4 KB ) - added by Wilfried Doberstein 2 years ago.
Logitech BRIO.jpg (389.9 KB ) - added by Wilfried Doberstein 2 years ago.
VM USB-Setting.jpg (44.7 KB ) - added by Wilfried Doberstein 2 years ago.
Issue YOGA.jpg (54.9 KB ) - added by Wilfried Doberstein 2 years ago.
YOGA USB 3.0.jpg (144.2 KB ) - added by Wilfried Doberstein 2 years ago.
DESKTOP USB 3.0.jpg (147.8 KB ) - added by Wilfried Doberstein 2 years ago.

Download all attachments as: .zip

Change History (37)

by Wilfried Doberstein, 2 years ago

Attachment: Screenshot.jpg added

Screenshot

by Wilfried Doberstein, 2 years ago

Attachment: VBox.log added

Logfile

comment:1 by pentagonik, 2 years ago

Can you please post your machine configuration file (.vbox, in your VM folder), too?

comment:2 by pentagonik, 2 years ago

Please try if setting the "screens" attribute to "1" in your .vbox configuration file:

e.g.

<VideoCapture enabled="false" screens="18446744073709551615" horzRes="1024" vertRes="768" rate="512" fps="25" maxTime="0" maxSize="0"/>

to

<VideoCapture enabled="false" screens="1" horzRes="1024" vertRes="768" rate="512" fps="25" maxTime="0" maxSize="0"/>

This needs VirtualBox to be shutdown completely first.

by Wilfried Doberstein, 2 years ago

comment:3 by Wilfried Doberstein, 2 years ago

I added screens="1" to line 138 and tried to start the VM. But I got the same error.

comment:4 by pentagonik, 2 years ago

There is a new 6.1 test build available here which should fix the issues.

Please let me know if this works for you now. Thanks!

by Wilfried Doberstein, 2 years ago

Attachment: MSIf0ae.LOG added

comment:5 by Wilfried Doberstein, 2 years ago

Hello pentagonik,

6.1.37 Setup ended prematuraly. Screenshot impossible. But I found the logfile, created during installation and attached it.

Last edited 2 years ago by Wilfried Doberstein (previous) (diff)

comment:6 by fth0, 2 years ago

Do you have UEFI Secure Boot enabled?

AFAIK, the VirtualBox drivers in Windows test builds are not attestation signed, and the test builds page therefore tells you to disable UEFI Secure Boot.

by Wilfried Doberstein, 2 years ago

Attachment: MS-Config.jpg added

by Wilfried Doberstein, 2 years ago

Attachment: MSI90822.LOG added

in reply to:  6 comment:7 by Wilfried Doberstein, 2 years ago

Replying to fth0:

Do you have UEFI Secure Boot enabled?

AFAIK, the VirtualBox drivers in Windows test builds are not attestation signed, and the test builds page therefore tells you to disable UEFI Secure Boot.

It took me 2 hours to disable Secure Boot (see attachment MS-Config.jpg. I also choosed F8 and switched off Driver signature Check. But all was in vain (see MSI90822.LOG)

comment:8 by fth0, 2 years ago

Ok, the following is only my personal summary of your issue:

  1. Initial problem: The VirtualBoxVM process had a Windows Application Crash. The VirtualBox rtR3WinUnhandledXcptFilter() was either not called or couldn't write its log messages into the VBox.log file because it couldn't acquire the necessary lock. I've seen this behavior in the VirtualBox forums a few times in the previous months. Additionally, you're using a non-release Windows 11 build which is generally not supported as host OS by VirtualBox (this doesn't mean that it couldn't work, though).
  1. pentagonik's suspicion: pentagonik probably suspected that you were experiencing another issue, where the Recording settings led to host memory exhaustion and to a Windows Application Crash. But your .vbox file showed the current version of the Recording settings (no "screens" attribute) being in use.
  1. Certificate issue: Trying to install a VirtualBox 6.1.37 test build showed certificate issues during the installation of the VirtualBox kernel drivers. Similar issues existed with the VirtualBox 6.1.35 test builds.

To further address number 1 above, I'd suggest to (re-)install VirtualBox 6.1.36. For a test, disable 3d Acceleration and USB and see if the issue persists.

comment:9 by Wilfried Doberstein, 2 years ago

I followed your advice and found USB-Controller 3.0 is the culprit (see attached USB-Setting and USB-Controller- and USB-Device-Tree).

I switched back to 6.1.34. Everything works fine, even login via face-recognishion with Logitech BRIO!

by Wilfried Doberstein, 2 years ago

Attachment: USB-Controller 3.0.jpg added

by Wilfried Doberstein, 2 years ago

Attachment: Logitech BRIO.jpg added

by Wilfried Doberstein, 2 years ago

Attachment: VM USB-Setting.jpg added

comment:10 by fth0, 2 years ago

Do you have a special reason to capture the Logitech BRIO as an USB device? As an alternative, you can remove the USB filter and use the webcam integration from the VM window's menu 'Devices > Webcams' instead.

in reply to:  10 comment:11 by Wilfried Doberstein, 2 years ago

Replying to fth0:

Do you have a special reason to capture the Logitech BRIO as an USB device? As an alternative, you can remove the USB filter and use the webcam integration from the VM window's menu 'Devices > Webcams' instead.

The special reason might be a lack of knowledge. I tried your alternative, but it doesn't work. During login I see the message (translated from German): The camera could not be activated. Please use PIN.

I would appreciate getting the method back, which worked in 6.1.34.

comment:12 by fth0, 2 years ago

Did you already try USB 2.0 instead of USB 3.0?

in reply to:  12 comment:13 by Wilfried Doberstein, 2 years ago

Replying to fth0:

Did you already try USB 2.0 instead of USB 3.0?

Connecting the Logitech BRIO to a port that supports USB 2.0 works for the Windows Host but not for the Guest. The VM-Guest is started without the initial issue. But I cannot configure Hello Face as an login option. After typing the PIN an error is shown for a split second, too short to identify.

I'll switch back to 6.1.34 and wait for a better build 6.1.38 / 40 / 42. Many thanks to pentagonik and fth0. But the issue is not worth to waste to much time. I'll only invest more time, if you are very keen to solve the problem.

comment:14 by fth0, 2 years ago

FWIW, I meant changing the configured virtual USB Controller, not using another physical port. The idea was to use the VirtualBox USB2 implementation, which helped a forum user who had a similar (if not the same) issue.

in reply to:  14 comment:15 by Wilfried Doberstein, 2 years ago

Replying to fth0:

FWIW, I meant changing the configured virtual USB Controller, not using another physical port. The idea was to use the VirtualBox USB2 implementation, which helped a forum user who had a similar (if not the same) issue.

Yes, I already tried this, tickking USB 2.0 (OHCI+EHCI)-Controller. The initial issue did not happen, but Hello Face wasn't possible.

comment:16 by fth0, 2 years ago

Thanks for the feedback! :)

comment:17 by Wilfried Doberstein, 2 years ago

In the meantime I tried another thing. Windows Host is Windows 10, Windows Guest is Windows 11 (the same as before). Activated USB 3.0 with an USB-Stick and at start-up the VM, I get the initial issue. Even when I only attach an ISO, I get the issue.

This means, the issue is only related to USB 3.0. No matter which kind of device, USB-Stick or Webcam. Now I will try to reproduce the issue on my Laptop (Lenovo Yoga 2 Pro).

Last edited 2 years ago by Wilfried Doberstein (previous) (diff)

comment:18 by Wilfried Doberstein, 2 years ago

I exported the VM in trouble from my desktop and imported it to my Notebook Yoga 2 Pro. At first with 6.1.34 and USB-Stick connected to a USB-3.0-Port and USB-Controller 3.0 ticked. No problem at startup. Then I installed 6.1.36 and did the same. Bingo! I got the same initial issue (see last attachment). BTW: I'm not interested in any workaround but would like to assist you in finding the bug.

Next I'll post the USB-Controller-Hardware on both machines.

by Wilfried Doberstein, 2 years ago

Attachment: Issue YOGA.jpg added

by Wilfried Doberstein, 2 years ago

Attachment: YOGA USB 3.0.jpg added

by Wilfried Doberstein, 2 years ago

Attachment: DESKTOP USB 3.0.jpg added

comment:19 by 56#-oop8ad, 2 years ago

In case it helps, I encountered the same VirtualBoxVM.exe application error after upgrading from virtualbox 6.1.34 to 6.1.36, and found the crash disappeared if I unplugged a (normally captured by guest) USB 3.0 hard disk from host.

I don't want to pollute the original ticket, but could attach vbox log file if helpful.

Config:

Host: Windows 11 Home edition, build 22000.856 Guest: Debian "Buster" server instance, USB filter configured to capture Western Digital USB 3.0 disk on host.

The crash also disappears if I downgrade VirtualBox and VB Guest additions to 6.1.34.

comment:21 by Wilfried Doberstein, 23 months ago

BTW: Virtualbox 7.0.0_BETA1 shows the same issue.

comment:22 by Wilfried Doberstein, 23 months ago

And Virtualbox 6.1.38 either.

comment:23 by fth0, 22 months ago

This issue should be fixed in the VirtualBox test builds 6.1.39r153816 and newer.

comment:24 by Wilfried Doberstein, 21 months ago

Could not install 6.1.39 and waited for 6.1.40. This version finally solved the issue. Many thanks to all who took part in analysing the issue.

This ticket may now be closed.

comment:25 by aeichner, 21 months ago

Resolution: fixed
Status: newclosed

Thanks for the report back!

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use