VirtualBox

#20976 closed defect (duplicate)

VM Windows 10 Guest crash on Host Fedora 35 kernel 5.17.12.200

Reported by: opabloc Owned by:
Component: other Version: VirtualBox 6.1.34
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

After a few minutes VM initiaded and running suddenly it crash with no error.

Attachments (2)

VBox.log.3 (189.9 KB ) - added by opabloc 22 months ago.
VBox.log.2 (171.5 KB ) - added by opabloc 22 months ago.

Download all attachments as: .zip

Change History (8)

by opabloc, 22 months ago

Attachment: VBox.log.3 added

by opabloc, 22 months ago

Attachment: VBox.log.2 added

comment:1 by Alexander G. M. Smith, 22 months ago

I get crashes in my Fedora 35 web server guest, using VirtualBox 6.34 (from the official VirtualBox repository), if the host OS kernel is Linux 5.17.12 or later. Works fine with 5.17.11 (Fedora 35 host OS, same problem also reported in Fedora 36).

The one oddity is that it only fails on some CPUs. Recent Intels and ancient AMDs work with kernel 5.17.12, but Intel Ivy Bridge and older have that problem with guest computations failing oddly (network data corruption and kernel crashes).

Discussed on the Fedora mailing list a bit under subject "VirtualBox and HOST kernel-5.17.12 weirdness": https://www.mail-archive.com/devel@lists.fedoraproject.org/msg181022.html

comment:2 by Ian Laurie, 22 months ago

For me all Linux guest VMs (various types) are failing on multiple Fedora 36 hosts with kernels 5.17.12 and later (5.17.12/13/14 tested so far). Everything works when I boot 5.17.11.

comment:3 by Dave W, 22 months ago

I am seeing the same thing. Fedora 35 running on Thinkpad T440p (i7-4700MQ CPU). If I run with kernel 5.17.9-200.fc35.x86_64 or 5.17.11-200.fc35.x86_64 everything works fine. I have a Windows 10 and Windows 7 guests hosted on virtualbox 6.1.34. If I upgrade the kernel to 5.17.12 or 5.17.13 then things break. Thing break in a number of ways:

  • The guest reboots spontaneously after a while
  • Applications in the guest lock up or start crashing. Browsers seem particularly prone to this. Both Chrome and Firefox will start to throw errors when accessing a page or will restart
  • The guest UI locks up so no i/o is possible and the only option is to power off the guest

comment:4 by Ingo, 22 months ago

Seeing the same here under Debian-Bullseye on a Core i5-3570K CPU and VirtualBox 6.1.34-150636.1~Debian~bullseye from Oracle repository. Guest running is Windows 10 with 2 cores assigned.

With stable kernel 5.10.113-1 all was fine, but this morning a updated kernel 5.10.120-1 was installed and the trouble started as Dave W describes:

  • The guest reboots spontaneously after a while.
  • Applications in the guest lock up or start crashing. Firefox seems particularly prone to this.
  • The guest UI locks up so no i/o is possible and the only option is to power off the guest.
  • Randomly CPU load on 2 cores (used by VBox-guest) raises to full load for a while and then again drops down to almost idle.

I downgraded to the previous kernel 5.10.113-1 for the time beeing and all is running smooth again. Probably one of the backported security-patches?

Here I got the changelog for the change from Debian kernel 5.10.113-1 to 5.10.120-1. In fact it includes the bunch of changes regarding "random": https://tracker.debian.org/news/1333344/accepted-linux-signed-amd64-5101201-source-into-stable-security-embargoed-stable-security/

Last edited 22 months ago by Ingo (previous) (diff)

comment:5 by jr1234, 22 months ago

Greetings. I'm seeing the same issue. Host is Fedora 35 (Intel + Nvidia drivers.) Guest is Windows 10. Everything runs perfect on host kernel 5.17.11. However, on 5.17.12 and 5.17.13 guest apps - particularly Chrome & Edge - crash with various errors. Sometimes the whole guest host reboots. Tested in both X and Wayland on host. Same results.

The one twist I have to add while debugging: I'm on a laptop with a Synaptics TouchPad. With no other pointing devices attached via USB, things seem to run fine. However, once I attach a USB pointing devices AND USE IT, that's when the crashes start. I've tried 3 different devices - 2 external touch pads, 1 mouse. If it's attached, but I only use the Synaptics TouchPad, no crashes.

Host Chrome and Firefox seems to run without an issue.

comment:6 by galitsyn, 22 months ago

Resolution: duplicate
Status: newclosed

Hi guys,

I think you are referring to the issue discussed in #20914. Some commits from kernel 5.18 were backported to older kernels as well. Test builds and patch from https://www.virtualbox.org/ticket/20914#comment:15 should have fix. Closing as duplicate.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use