VirtualBox

Ticket #20792 (closed defect: fixed)

Opened 4 months ago

Last modified 4 weeks ago

Regression in latest version of VB

Reported by: fblondiau Owned by:
Component: other Version: VirtualBox 6.1.32
Keywords: Cc:
Guest type: other Host type: Mac OS X

Description

Hello,

After updating to version 6.1.32 r149290 (Qt5.6.3) on my Mac, a previously working VM refused to start ... with a strange message talking about VERR_PROC_NO_ARG_TRANSLATION (1).

It appeared that my VM was using a egrave character... after replacing this è with a e, it stared fine.

This egrave was not a problem with previous versions.

Best regards

(1) Failed to open a session for the virtual machine DouWère Ubuntu.

Could not launch the VM process for the machine 'DouW�re Ubuntu' (VERR_PROC_NO_ARG_TRANSLATION).

Result Code: VBOX_E_IPRT_ERROR (0x80BB0005) Component: MachineWrap Interface: IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}

Change History

comment:1 Changed 4 months ago by fth0

There's a forum user with a similar issue:  Failed to start Win10 VM after upgrade to 6.1.32.

The forum user has a VM named "Win10", containing no special characters. Changing the system language to English and the environment variables LANG and LC_CTYPE from "ja_JP.UTF8" to "C" (LC_ALL not set) didn't help.

comment:2 Changed 4 months ago by fth0

I just came across an iMac with macOS Catalina, updated VirtualBox to 6.1.32, cloned a minimal VM named "Empty" and thereby added an "-è" to the name. Starting the VM results in the VERR_PROC_NO_ARG_TRANSLATION error message. The VBoxSVC.log file contains the following lines (it's a German language installation with LANG=de_DE.UTF-8 BTW):

00:01:18.207730 MachineClone Saving settings file "/Users/fth0/VirtualBox VMs/Empty-è/Empty-è.vbox" with version "1.15-macosx"
00:01:18.715466 nspr-5   Saving settings file "/Users/fth0/Library/VirtualBox/VirtualBox.xml" with version "1.12-macosx"
00:01:24.663672 nspr-2   Failed to convert argument #2 'Empty-è' to 'US-ASCII': VERR_NO_TRANSLATION
00:01:24.663772 nspr-2   ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={85632c68-b5bb-4316-a900-5eb28d3413df} aComponent={MachineWrap} aText={Could not launch the VM process for the machine 'Empty-è' (VERR_PROC_NO_ARG_TRANSLATION)}, preserve=false aResultDetail=-22425
Last edited 4 months ago by fth0 (previous) (diff)

comment:3 Changed 4 months ago by klaus

Thanks for the useful data point. Need to find out why VBoxSVC thinks it should convert to ASCII. Definitely not going to work right.

comment:4 Changed 4 months ago by Anaconda444

I have similar problem with 6.1.32 and Debian 11 VM. Suddenly I am not able to start the VM, it freezes and when I stop it it gives me error:

The VM session was aborted. Result Code: E_FAIL (0x80004005) Component: SessionMachine Interface: ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

My VM is not named with special characters.

When I try the same VM (took a clone) on another computer BUT with 6.1.30 version of VirtualBox, all works.

So I guess the problem is related to VBox 6.1.32 (which was working couple of days without problems)

My host machine is Windows 10 (with VB 6.1.32 and the the 6.1.30 is on Windows 11)

I am not sure, but I did some update for Windows 10 just before this problem came, but not sure is it related...

UPDATE: Downgraded Vbox from 6.1.32 to 6.1.30 on Windows 10 machine but it didnt help. Still all works on Windows 11 6.1.30.

UPDATE2: taking a clone from the aborted snapshot and starting it on a same host machine fixed the issue.

Last edited 4 months ago by Anaconda444 (previous) (diff)

comment:5 Changed 4 months ago by pentagonik

For those who experience the VM starting issues above: Did you already try to start the VM via command line, e.g.

VirtualBoxVM --startvm "<My-VM>"

?

Another option would be to start the VM selector manually on the command line via

VirtualBox

and then try to start the VM in question.

Last edited 4 months ago by pentagonik (previous) (diff)

comment:6 Changed 4 months ago by fth0

@pentagonik: I can confirm that both workarounds successfully start the VM (as you probably expected).

comment:7 follow-up: ↓ 8 Changed 3 months ago by pentagonik

Test build 149712 for VirtualBox 6.1 should contain fix -- you can get the latest test builds on the https://www.virtualbox.org/wiki/Testbuilds page.

Please let me know if this fixes the issue for you. Thank you!

comment:8 in reply to: ↑ 7 Changed 3 months ago by fth0

Replying to pentagonik:

Please let me know if this fixes the issue for you. Thank you!

I've installed VirtualBox 6.1.33r149712 on the iMac with macOS Catalina, without disabling SIP (being connected via Screen Sharing). After starting the VM, the expected "Kernel drivers not installed (rc=-1908)" error was displayed. The VBoxSVC.log showed the message "Launched VM: 1984151760 pid: 2284 (0x8ec) frontend: GUI/Qt name: Empty-ü" instead of the previously encountered VERR_PROC_NO_ARG_TRANSLATION error.

From my POV, the issue is fixed. I can neither confirm nor deny that the VM would run, though. ;)

comment:9 Changed 3 months ago by pentagonik

Yes, this is to be expected -- without disabling SIP you cannot run VirtualBox test builds on macOS.

Thanks for testing though!

comment:10 Changed 4 weeks ago by galitsyn

  • Status changed from new to closed
  • Resolution set to fixed

The issue should be fixed in VirtualBox 6.1.34. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use