VirtualBox

Ticket #20636 (new defect)

Opened 6 weeks ago

Last modified 3 weeks ago

VBoxHeadless does not run in macOS Monterey 12.0.1 => fixed in SVN/next maintenance

Reported by: granada29 Owned by:
Component: other Version: VirtualBox 6.1.28
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

I can start the VM normally and it runs as expected. When starting ss "Headless" it immediately aborts.

VBox.log and the VBoxHeadless crash dump attached.

Attachments

VBox.log Download (185.4 KB) - added by granada29 6 weeks ago.
VBoxHeadless-2021-10-26-144900.ips.zip Download (3.6 KB) - added by granada29 6 weeks ago.
VBoxHeadless crash dump - open with Console.app
VBoxHeadless Crash Reports.zip Download (9.8 KB) - added by seenukarthi 6 weeks ago.

Change History

Changed 6 weeks ago by granada29

Changed 6 weeks ago by granada29

VBoxHeadless crash dump - open with Console.app

comment:1 Changed 6 weeks ago by r

official Monterey, Virtual Box 6.1.28 on MBP 16 Detached start or Headless start ends with error bellow:

Failed to open a session for the virtual machine Oracle DB Developer VM.
The virtual machine 'Oracle DB Developer VM' has terminated unexpectedly during startup because of signal 10.
Result Code:	NS_ERROR_FAILURE (0x80004005)
Component:	MachineWrap
Interface:	IMachine {85632c68-b5bb-4316-a900-5eb28d3413df

No VBox.log was written to disk during Headless start.

Here is the cut from older log.

00:00:00.167394 VirtualBox GUI (separate) 6.1.28 r147628 darwin.amd64 (Oct 18 2021 19:59:14) release log
00:00:00.167397 Log opened 2021-10-25T21:08:49.968813000Z
00:00:00.167398 Build Type: release
00:00:00.167406 OS Product: Darwin
00:00:00.167410 OS Release: 21.1.0
00:00:00.167414 OS Version: Darwin Kernel Version 21.1.0: Wed Oct 13 17:33:23 PDT 2021; root:xnu-8019.41.5~1/RELEASE_X86_64
00:00:00.167472 DMI Product Name: MacBookPro16,1
00:00:00.167502 DMI Product Version: 1.0
00:00:00.167505 Firmware type: failed - VERR_NOT_SUPPORTED
00:00:00.167512 Host RAM: 32768MB (32.0GB) total, 24083MB (23.5GB) available
00:00:00.167516 Executable: /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM
00:00:00.167516 Process ID: 1020
00:00:00.167516 Package type: DARWIN_64BITS_GENERIC

comment:2 Changed 6 weeks ago by ssh22

Not sure if it's the same issue, but it's also not working with Vagrant. I can start VM's manually from the VirtualBox UI, but can't start anything from Vagrant.

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Clearing any previously set network interfaces...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage: error: Context: "RTEXITCODE handleCreate(HandlerArg *)" at line 95 of file VBoxManageHostonly.cpp

MacOS Monterey 12.0.1 VirtualBox: 6.1.28 r147628 (Qt5.6.3) Vagrant 2.2.18 Everything is updated to the latest version.

comment:3 Changed 6 weeks ago by seenukarthi

I'm Having the same issue VBoxHeadless is crashing in macOs Monterey. attached the crash reports.

Changed 6 weeks ago by seenukarthi

comment:4 follow-up: ↓ 5 Changed 6 weeks ago by klaus

Yes, (unfortunately) reproducible. Slipped somehow through when we tested with the beta versions of macOS Monterey. Will try to provide a fixed build in the near future.

comment:5 in reply to: ↑ 4 Changed 6 weeks ago by ssh22

Replying to klaus:

Yes, (unfortunately) reproducible. Slipped somehow through when we tested with the beta versions of macOS Monterey. Will try to provide a fixed build in the near future.

I think thats the reason why most Vagrant users are having issues right now:  https://github.com/hashicorp/vagrant/issues/12557

comment:6 Changed 6 weeks ago by wilburx3

I start all my VMs on macOS 12.0.1 via terminal with the headless switch. I receive the same error, signal 10, on my Windows and Linux guests machines.

VBoxManage startvm MACHINE_NAME --type headless

VBoxManage: error: The virtual machine 'MACHINE_NAME' has terminated unexpectedly during startup because of signal 10
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

comment:7 follow-up: ↓ 13 Changed 6 weeks ago by aeichner

  • Summary changed from VBoxHeadless does not run in macOS Monterey 12.0.1 to VBoxHeadless does not run in macOS Monterey 12.0.1 => fixed in SVN/next maintenance

Will be fixed in the next maintenance release.

comment:8 follow-up: ↓ 9 Changed 6 weeks ago by ssh22

There is another thing (when using Vagrant + VirtualBox). Version 6.1.28 did not respect the IP address set into the Vagrantfile. It just boots the machine with incorrect IP. Downgrading to 6.1.26 adds the correct IP and it works perfectly fine (not in headless mode ofc.)

comment:9 in reply to: ↑ 8 Changed 6 weeks ago by janitor

Replying to ssh22:

There is another thing (when using Vagrant + VirtualBox). Version 6.1.28 did not respect the IP address set into the Vagrantfile.

#20626?

comment:10 follow-up: ↓ 11 Changed 6 weeks ago by ynuyasha

Same issue VM not starting in headless mode vagrant + virtualbox 6.1.28 on Monterey.

And same issue MacOS 11.x Vagrant + virtualbox 6.1.28 network not keep ipaddress. With downgrade to 6.1.26 all works.

comment:11 in reply to: ↑ 10 Changed 6 weeks ago by petro

Replying to ynuyasha:

Same issue VM not starting in headless mode vagrant + virtualbox 6.1.28 on Monterey.

And same issue MacOS 11.x Vagrant + virtualbox 6.1.28 network not keep ipaddress. With downgrade to 6.1.26 all works.

Same issue, but without vagrant, virtualbox 6.1.28 on MacOS 12.0.1 doesn't assign IP address to host only vboxnet0 iface, therefore no route in table and VM's are inaccessible thru network, and 6.1.26 do the job, but both versions won't start with "--type headless" switch

Last edited 6 weeks ago by petro (previous) (diff)

comment:12 Changed 6 weeks ago by lukeb

Also having this same issue with Mac OSX Monterey and vagrant and virtualbox.

comment:13 in reply to: ↑ 7 Changed 5 weeks ago by wilburx3

Replying to aeichner:

Will be fixed in the next maintenance release.

Will this be three months till release?

comment:14 Changed 5 weeks ago by klaus

Hard to predict right now when the next maintenance release will happen. At the latest it will be in January, but I wonder if using a test build would be an option (and we might do a special test build which is notarized, i.e. wouldn't require the usual disabling of security as normal test builds).

Just for this single fix it'd be a bit much effort to do a maintenance release. However there might be other fixes coming which justify it...

comment:15 Changed 5 weeks ago by lukeb

Those of us that have upgraded to Mac OSX Monterey are sunk while VirtualBox doesn't work with it, since downgrading OS isn't any option without a recent Time Machine backup.

comment:16 Changed 5 weeks ago by klaus

The latest 6.1 test build has the fix, but the usual "not notarized" caveat applies which is documented there, with the "disable SIP" workaround.

Oh, and before I forget: the "issue" with vboxnet not getting addresses and so on is unrelated to this ticket. See #20626 for pointers to the relevant information.

comment:17 Changed 5 weeks ago by ssh22

I see issue #20637 has been closed as duplicate off this ticket. So, keep in mind that according to issue #20637 "The VirtualBox kext bundles are not automatically loaded after a system boot. I can confirm this issue too...

"

comment:18 Changed 5 weeks ago by coroos

Someone marked #20637 as a duplicate but forgot to copy across very useful information: Load your kext's manually like so:

sudo kextload -b org.virtualbox.kext.VBoxDrv;
sudo kextload -b org.virtualbox.kext.VBoxNetFlt;
sudo kextload -b org.virtualbox.kext.VBoxNetAdp;
sudo kextload -b org.virtualbox.kext.VBoxUSB;

and then start the VM from the UI (or the command line) as Normal (not headless).

See comments above and links for why.

comment:19 Changed 5 weeks ago by jpeters86

Original post: I am wondering, since lots of people are waiting for the official maintenance release, is there a releasedate planned?

Edit: Sorry, I see this was already appointed above (a new release is much work, so probably not for this issue)

Last edited 5 weeks ago by jpeters86 (previous) (diff)

comment:20 Changed 5 weeks ago by antonl

Fix for network issue: create /etc/vbox/networks.conf on the host machine with the following content

* 0.0.0.0/0 ::/0

comment:21 Changed 4 weeks ago by RedHood

Of course this is isn't a huge issue. It's Oracle. I'm thinking I might have to switch to using Docker containers if this doesn't get fixed soon. The company I work for is only using VirtualBox because the lead developer that is leaving liked using VirtualBox. Guess now is the time to make a suggestion to move to using Docker.

comment:22 Changed 4 weeks ago by lite

Please consider a maintenance release for 6.28 to fix headless issue on macos monterey.

comment:23 follow-up: ↓ 24 Changed 4 weeks ago by klaus

Could you try with this test build? It is notarized, to avoid the usual SIP trouble...

comment:24 in reply to: ↑ 23 Changed 4 weeks ago by gandalftw

Replying to klaus:

Could you try with this test build? It is notarized, to avoid the usual SIP trouble...

After installing this build headless start is working and vagrant as well.

Last edited 4 weeks ago by gandalftw (previous) (diff)

comment:25 Changed 4 weeks ago by rtpHarry

The test build worked for me to load it up as a headless, but the ip address mapping doesn't seem to be working.
I'm using this with VVV, and when running it I get this error:

==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
The IP address configured for the host-only network is not within the
allowed ranges. Please update the address used to be within the allowed
ranges and run the command again.

  Address: 192.168.50.4
  Ranges: 192.168.56.0/21

Valid ranges can be modified in the /etc/vbox/networks.conf file. For
more information including valid format see:

  https://www.virtualbox.org/manual/ch06.html#network_hostonly

I can set the ip using the config.yml, which I do, and it then boots ok, but nothing is accessible. I've gone into this in a bit more detail here:


 https://github.com/Varying-Vagrant-Vagrants/VVV/issues/2554

comment:26 Changed 4 weeks ago by klaus

The "remaining issue" with host-only networks is a behavior change in 6.1.28. See https://www.virtualbox.org/manual/ch06.html#network_hostonly

comment:27 Changed 3 weeks ago by dpacak

I used test build 6.1.29r148140 on macOS Monterey (Version 12.0.1) with  Vagrantfile with port forwards and it works like a charm.

comment:28 Changed 3 weeks ago by cfdude

If you can't use a test build and are using Vagrant, you can put this in the vagrantfile to at least be operational until this is released:

config.vm.provider "virtualbox" do |vb|

vb.gui = true

end

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use