VirtualBox

Ticket #20545 (closed defect: duplicate)

Opened 11 months ago

Last modified 9 months ago

Windows 11 Support

Reported by: metalfirefox Owned by:
Component: host support Version: VirtualBox 6.1.26
Keywords: windows11 host_support Cc:
Guest type: all Host type: Windows

Description

The Ticket with ID '#20536' describes what I believe is the exact same problem. More context is given here.

First the error - VERR_NEM_VM_CREATE_FAILED

Failed to get device handle and/or partition ID for 000000000237abe0 (hPartitionDevice=0000000000000cf1, Last=0xc0000002/1) (VERR_NEM_VM_CREATE_FAILED).

Result Code: 
E_FAIL (0x80004005)
Component: 
ConsoleWrap
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Steps to get this Error:

  • A clean install of Windows 11, any build (if you upgrade Windows 10 -> 11 with VirtualBox working on Windows 10, no errors will be given.)
  • Install any Guest Machine. I have tried windows, Linux (ubuntu 20.04 and kali).

What Happens: The application of VirtualBox works fine. Any VM that you press START on though pops up a window, shortly (like after a second), destroys the window and results in the error as shown above.

Context: I did get things to work by turning off Windows Hypervisor in additional settings and manually turning off it off via the command:

bcdedit /set hypervisorlaunchtype off

However, this should not be a valid solution as WSL2 and other applications depend on the use of Hypervisor. This would also limit brand new users from trying VirtualBox having no technical background.

It is very likely the error will exists on release. It's probably a certain file or variable that has been moved from Windows 10->11 and VirtualBox is unable to find it resulting in the error. It would be nice to have this bug sorted out before release.

Change History

comment:1 Changed 9 months ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #20536.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use