VirtualBox

Ticket #2053 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

kvm check fails

Reported by: crissi Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I have problems to start an vm because vbox 2.0.0 tells me there is kvm enabled but thats not true. Its definitly an module:

develop:/home/crissi# modinfo kvm
filename:       /lib/modules/2.6.25-2-686/kernel/arch/x86/kvm/kvm.ko
license:        GPL
author:         Qumranet
depends:
vermagic:       2.6.25-2-686 SMP mod_unload 686

and its not loaded:

develop:/home/crissi# lsmod | grep kvm
develop:/home/crissi#

Happens on Debian Lenny running 2.6.25-2-686 distribution kernel.

Additional info: I had installed 1.6.4 which was running fine. Then I upgraded to 1.6.6 and it runs fine too. Then I upgraded to 2.0.0 (using the VirtualBox-1.6.6-Linux_x86.run binary) and it claims about kvm. I went back to 1.6.6 (fixed the xml too) and it also claims about kvm. I dont had rebooted from working vbox 1.6.4.

Change History

comment:1 Changed 6 years ago by sandervl73

  • Priority changed from critical to major

VBox.log?

Somebody is using VT-x or AMD-V, so that's why the warning is there. On Linux we just assume it's KVM. It doesn't give fake warnings.

comment:2 Changed 6 years ago by sandervl73

Make sure there are no duplicate vbox drivers around too. Maybe the upgrade went wrong or something.

comment:3 Changed 6 years ago by frank

  • Description modified (diff)

AFAIR you wrote somewhere that indeed kvm was involved, correct?

comment:4 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

I'm just assuming that KVM was active. Reopen if you are absolutely sure that this is not true.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use