VirtualBox

Ticket #20484 (new defect)

Opened 14 months ago

Last modified 9 months ago

On FreeBSD host VMs with pulseaudio audio driver fail to start

Reported by: madpilot Owned by:
Component: audio Version: VirtualBox 6.1.24
Keywords: FreeBSD Cc:
Guest type: all Host type: other

Description

I'm testing updating the FreeBSD VirtualBox port.

Starting with 6.1.24, I'm unable to start any VM using pulseaudio as the audio driver. Problem is present in 6.1.26 too.

I'm attaching the log and the vbox file for a test machine.

pulseaudio was working fine in 6.1.22.

If any further information is required please ask and I'll try to provide whatever is needed.

Attachments

test.vbox Download (2.9 KB) - added by madpilot 14 months ago.
Machine configuration xml
test-2021-08-01-18-29-51.log Download (37.8 KB) - added by madpilot 14 months ago.
Log file

Change History

Changed 14 months ago by madpilot

Machine configuration xml

Changed 14 months ago by madpilot

Log file

comment:1 Changed 14 months ago by madpilot

The issue is also described here:

 https://reviews.freebsd.org/D31264

comment:2 Changed 14 months ago by Derek Evan Schrock

CC myself.

comment:3 Changed 14 months ago by grahamperrin

Cc grahamperrin

comment:4 Changed 9 months ago by tim.mooney

This exact same problem impacts OpenIndiana too.

Using the PulseAudio backend was previously working for audio in guests hosted on the Illumos distro OpenIndiana, but now any VM configured with an audio device gets the error reported in the linked FreeBSD bug report.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use