VirtualBox

Ticket #20456 (closed defect: duplicate)

Opened 4 months ago

Last modified 3 months ago

Guru Mediation Crash when 5-level page tables are enabled

Reported by: Larry Finger Owned by:
Component: other Version: VirtualBox 6.1.22
Keywords: Cc:
Guest type: other Host type: other

Description

When 5-level page tables are enabled in the host, starting most VMs result in a guest crash with the Guru Mediation page being shown. This happens with 6.1.20, 6.1.22, and test build 6.1.x revision 145620. The machine log for Windows 10 is attached.

Attachments

Windows 10 Clone-2021-07-12-15-12-18.log Download (313.1 KB) - added by Larry Finger 4 months ago.
VM Log
VBox.log Download (261.6 KB) - added by frispete 3 months ago.
Another Log of such a crash
changes-linux-5.13-randomize-kstack-offset.diff Download (851 bytes) - added by klaus 3 months ago.

Change History

Changed 4 months ago by Larry Finger

VM Log

comment:1 Changed 4 months ago by Larry Finger

When this crash happens, the host log has

[ 234.088947]

!!Assertion Failed!! Expression: pCritSect->s.Core.NativeThreadOwner == hNativeSelf Location : /home/vbox/tinderbox/6.1-lnx64-rel/src/VBox/VMM/VMMAll/PDMAllCritSect.cpp(579) int PDMCritSectLeave(PDMCRITSECT*)

[ 234.088963] ffffae7c82e9e000 <R3_STRING>: ffffffffffffffff != 00007f479c2b2640; cLockers=-1 cNestings=1

comment:2 Changed 4 months ago by klaus

This is weird. Why would enabling 5 level page tables have any real effect on your system? Your CPU was launched in 2013, and the first CPUs which have 5 level page tables became available this year. I don't believe you have a time machine in your basement :)

comment:3 Changed 4 months ago by fth0

In addition to klaus' question above:

Can you easily reproduce the issue after rebooting the Linux host? If so, can you prevent it by booting the Linux host kernel 5.13 with the no5lvl parameter?

Last edited 4 months ago by fth0 (previous) (diff)

comment:4 Changed 3 months ago by bird

Are you sure it's the 5-level page tables and not CONFIG_RANDOMIZE_KSTACK_OFFSET_DEFAULT being enabled? If the latter is enabled, try adding randomize_kstack_offset=0 to the linux kernel command line and see if it helps.

Changed 3 months ago by frispete

Another Log of such a crash

comment:5 Changed 3 months ago by frispete

Have you noticed the weird display size of the vmsvga adapter, similar to Larry's:

00:00:00.833768 Display size:       4294967295x4294967295 4294967295bpp

On another VM, I found this in addition:

00:00:00.945302 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:00:00.945322 emR3Debug: rc=VERR_INVALID_STATE
00:00:01.379554 GUI: UIMachineViewNormal::resendSizeHint: Restoring guest size-hint for screen 0 to 800x600
00:00:01.380324 ERROR [COM]: aRC=NS_ERROR_INVALID_ARG (0x80070057) aIID={4680b2de-8690-11e9-b83d-5719e53cf1de} aComponent={DisplayWrap} aText={Argument aWidth is invalid (must be aWidth != 0 && aWidth <= 32767)}, preserve=false aResultDetail=0
00:02:06.590415 GUI: User request to power VM off on Guru Meditation.
00:02:06.590435 GUI: Passing request to power VM off from machine-logic to UI session.
00:02:06.590436 GUI: Powering VM down on UI session power off request...

Unfortunately, it's not telling us the value of aWidth, but 0xffffffff qualifies easily as being outside this range. I'll try bird's suggestion in a minute.

comment:6 Changed 3 months ago by fth0

Please try the VirtualBox test builds 6.1.23r145697 (or newer) that are supposed to fix VirtualBox issues on hosts with Linux kernel 5.13, and report back. TIA.

Last edited 3 months ago by fth0 (previous) (diff)

Changed 3 months ago by klaus

comment:7 Changed 3 months ago by klaus

The diff contains the fix. Useful for people who build VirtualBox packages themselves, because this isn't a tweak to the vboxdrv kernel module source code.

comment:8 Changed 3 months ago by bird

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #20452.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use