VirtualBox

Ticket #203 (closed defect: wontfix)

Opened 7 years ago

Last modified 6 years ago

Vboxdrv.ko crashes Centos 5 with Xen installed

Reported by: graham27 Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Was hoping to run Xen under CentOS5 for Linux os's and then use VirtualBox for the windows ones. Downloaded and installed the VirtualBox_1.3.8_Linux_x86.run version and after coming to end and saying success, it totally crashs the system and reboots, and then loads upto loading the vboxdrv module and then crashes and reboots again. I had to remove the vboxdrv from the kernel/misc dir to get my system to load back to desktop. Just wondered is there a work around to get this to work under the Xen kernel - 2.6.18-1.2747.el5xen ?

Change History

comment:1 Changed 7 years ago by frank

We have not tried Xen kernels as host kernels. However, your problem is not necessarily Xen-related. Which package did you use for installing? The .run package?

comment:2 Changed 7 years ago by beehoney

was there a resolution to this as i am having the same issue i tried to cheap and use the enterprise linux 4 rpm version but that crashed my computer so i tried the all distribution .run version and ran that and it creates a kernel dump also !! is this an issue with Centos?or EL5 or vritualbox any ideas ? i hope someone can help !!

comment:3 Changed 7 years ago by StuartGathman

Having virtualbox run in dom0 under Xen would be quite tricky. Xen has already installed a hypervisor running in ring 0. The dom0 kernel itself does not run in ring 0. Virtualbox would have to cooperate with the xen hypervisor - very different from adding a hypervisor to a standard EL5 kernel. I am about to try virtualbox on a standard EL5 kernel, and will let you know how it goes. But I think you are out of luck for running xen and virtualbox simultaneously (except maybe with full hardware virtualization including ring 0 emulation).

comment:4 Changed 6 years ago by grantmasterflash

It does in fact work on the stock CentOS kernels and not the Xen kernel. Interestingly enough VMware server and Qemu work on the Xen kernels. I too need both working the the same machine unless I can figure out how to get VirtualBox to similate a sda drive.

comment:5 Changed 6 years ago by sandervl73

VMWare server works with the Xen kernel? Somehow I find that hard to believe. The dom0 has to play nice and VMWare certainly doesn't. And neither does VirtualBox. The two systems are simply incompatible.

It would indeed be nice if our driver didn't crash you system, but you can forget about *using* VirtualBox in a Xen domain.

comment:6 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use