VirtualBox

Ticket #2023 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

VirtualBox hangs and system must be rebooted after suspend/resume => only with VT-x/AMD-V

Reported by: esac Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Linux rayben 2.6.24-21-generic #1 SMP Mon Aug 25 16:57:51 UTC 2008 x86_64 GNU/Linux

Guest is running, and I put my laptop to sleep. After resume, VirtualBox window is frozen, and can't even be closed. Tried a force qiut and killing all vbox processes as well as restarting vboxdrv and vboxnet. Only way to even get vXM console to start was to reboot. This happens 100%

Change History

comment:1 Changed 6 years ago by frank

Did you start your VM with VT-x or AMD-V enabled?

comment:2 Changed 6 years ago by elgreengeeto

I had the same problem running an XP guest on an Ubuntu (v8.10) host, running VBox v1.6.2. I'm on a Thinkpad X61. Even if I pause the virtual machine before putting the host to sleep, when I try to un-pause the virtual machine it crashes just the same.

Inspired by Frank's question I then turned off VT-x/AMD-v and indeed the problem went away, I can suspend/resume my Ubuntu host without VBox crashing.

Sadly it is noticeably slower without the hardware virtualization, I'd love to hear if anyone has a fix for this that would allow me to re-enable VT-x/AMD-v!

comment:3 Changed 6 years ago by frank

  • Component changed from other to VMM/HWACCM
  • Summary changed from VirtualBox hangs and system must be rebooted after suspend/resume to VirtualBox hangs and system must be rebooted after suspend/resume => only with VT-x/AMD-V

There is no fix yet but we are aware of this problem. The reason is that VirtualBox currently is not notified if the host goes to sleep and it is not notified if the host wakes up again. Therefore VT-x or AMD-V respectively is not re-enabled properly.

comment:4 Changed 6 years ago by sandervl73

Duplicate of 1660. (windows host there, but the same problem)

comment:5 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use