VirtualBox

Ticket #20222 (closed defect: fixed)

Opened 22 months ago

Last modified 7 months ago

GUI BUG: file picker on Linux KDE Plasma does not handle mouse, unusable

Reported by: ValdikSS Owned by: gombara
Component: GUI Version: VirtualBox 6.1.18
Keywords: Cc:
Guest type: other Host type: Linux

Description

VirtualBox file picker dialog (ISO or HDD selection, etc) does not handle mouse events when running on KDE Plasma 5. All dialog elements are not clickable. You can still use it with keyboard.

When opening the dialog, Qt outputs the following warning into console:

Qt WARNING: QWidgetWindow(0x681e4a0, name="UIMachineSettingsStorageWindow") must be a top level window.

I'm not sure whether is this a Qt, VirtualBox, KDE Plasma or packaging issue, but Mageia bug reporter  https://bugs.mageia.org/show_bug.cgi?id=27433 says that rebuilding the same package under older version of distro fixes the issue.

This is happening in Virtualbox 6.1.18 too, but only in Plasma5. Doesn't happen under GNOME. Curiously the same .src.rpm rebuilt under Mageia7 doesn't show up the problem under Plasma.

Also reproducible on Fedora 33 with RPMFusion repository. Bug:  https://bugzilla.rpmfusion.org/show_bug.cgi?id=5929#c1

### HOW TO REPRODUCE

  1. Open VirtualBox
  2. Create new VM or use existing
  3. Open VM settings
  4. Go to "storage" tab
  5. Click on any drive → cilck on HDD or optical icon → Choose a disk file… dropdown element

### EXPECTED RESULT File picker dialog works as usual, you can select ISO or disk drive file with a mouse.

### ACTUAL RESULT You can't click on any dialog element.

### WORKAROUND Quick and dirty patch is in the attachment.

KDE Plasma: 5.20.5 KDE Frameworks: 5.78.0 Qt version: 5.15.2

Attachments

vbox-fix-file-picker.patch Download (657 bytes) - added by ValdikSS 22 months ago.
VBox File picker patch

Change History

Changed 22 months ago by ValdikSS

VBox File picker patch

comment:1 Changed 21 months ago by gombara

  • Owner set to gombara
  • Status changed from new to assigned

comment:2 follow-up: ↓ 4 Changed 21 months ago by gombara

I cannot reproduce this. Tried on a development build from the top of our 6.1 branch on a KDE Plasma 5 (Linux Mint 20.1).

comment:3 Changed 20 months ago by Omano

I can confirm this exact same issue on Manjaro KDE. It has been like that for months now.

comment:4 in reply to: ↑ 2 Changed 20 months ago by ValdikSS

Replying to gombara:

I cannot reproduce this. Tried on a development build from the top of our 6.1 branch on a KDE Plasma 5 (Linux Mint 20.1).

This might be Qt related. Could you please test with Fedora 33?

comment:5 Changed 20 months ago by ValdikSS

Workaround:

KDE_FULL_SESSION= XDG_CURRENT_DESKTOP= DESKTOP_SESSION= virtualbox

comment:7 Changed 10 months ago by borgille1

FYI, I was able to reproduce this issue in with VirtualBox 6.1.32 r149290 on Kubuntu 21.10 (impish), which uses KDE Frameworks 5.86.0 (Plasma 5.22.5). The workaround seems to be working on my machine.

comment:8 Changed 7 months ago by gombara

This bug has been fixed for VirtualBox version > 6.1.34.

comment:9 Changed 7 months ago by gombara

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use