VirtualBox

Ticket #20193 (closed defect: duplicate)

Opened 8 months ago

Last modified 8 months ago

Kernel 5.11 and Testbuild 142777: modules don't compile

Reported by: joeAverage Owned by:
Component: other Version:
Keywords: Kernel 5.11 Cc: sixpack13@…
Guest type: Windows Host type: Linux

Description

Kernel 5.11 and Testbuild 142777: modules don't compile

Attachments

vbox-setup.log Download (12.6 KB) - added by joeAverage 8 months ago.
vbox-setup.log

Change History

Changed 8 months ago by joeAverage

vbox-setup.log

comment:1 in reply to: ↑ description Changed 8 months ago by joeAverage

Replying to joeAverage:

s/Testbuild 142777/VirtualBox-6.1.19-142777-Linux_amd64/

Last edited 8 months ago by joeAverage (previous) (diff)

comment:2 Changed 8 months ago by dinosaur0

I fixed this bug by simply adding '#include <linux/ethtool.h>' to VirtualBox/src/vboxhost/vboxnetflt/linux/VBoxNetFlt-linux.c in VBox v6.1.18 installation.

comment:3 Changed 8 months ago by joeAverage

Thanks, that fixed it for testbuild too.

comment:4 Changed 8 months ago by paulson

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as a duplicate of #20198. As mentioned here and there the workaround is to add '#include <linux/ethtool.h>' to VirtualBox/src/vboxhost/vboxnetflt/linux/VBoxNetFlt-linux.c.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use