VirtualBox

Ticket #20192 (new defect)

Opened 22 months ago

Last modified 21 months ago

Virtual Machine does not start on M1 Mac

Reported by: mheimqpm Owned by:
Component: other Version: VirtualBox 6.1.18
Keywords: M1, Mac, ARM Cc:
Guest type: all Host type: Mac OS X

Description

Device: MacBook Pro 13-inch, 2020, M1

Software: macOs 11.1

Installation of VirtualBox is working. Trying to create and start an Ubuntu-Machine with VirtualMachine by using the following command in existing project:

vagrant up

After short time the following message appears:

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage: error: Context: "RTEXITCODE handleCreate(HandlerArg *)" at line 95 of file VBoxManageHostonly.cpp

There is no file like /dev/vboxnetctl. When installing VirtualBox there is no option in the security settings to accept. Related posts recommend reinstalling of VirtualBox. Tried multiple times without success. There is still no possibility to adjust the privacy settings of Big Sur for VirtualBox.

Other way to resolve the problem: Trying to restart with:

sudo "/Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh" restart 

This doesn’t work and leads to following error:

Error Domain=KMErrorDomain Code=71 "Incompatible architecture: Binary is for x86_64, but needed arch arm64e" UserInfo={NSLocalizedDescription=Incompatible architecture: Binary is for x86_64, but needed arch arm64e}

It seems that VirtualBox is not compatible to the newest Mac ARM architecture. Is there a plan to fix that in the upcoming releases?

Change History

comment:1 Changed 22 months ago by klaus

Your observation is correct. VirtualBox works on Macs with Intel CPU only.

What do you want to achieve with your vagrant setup? You talk about running Ubuntu, which sounds like you're expecting to run x86/amd64 code. I hope you're aware that M1 based Macs can run x86/amd64 code for applications (using Rosetta), but they are not x86/amd64 compatible. You shouldn't buy ARM based hardware when you intend to run OSes which are for AMD/Intel CPUs.

Regarding plans: not allowed to talk about the future (against Oracle policy).

comment:2 Changed 21 months ago by nigam214

Regarding plans: not allowed to talk about the future (against Oracle policy).

our major development depends on the virtual box and we use Mac. Unfortunately, bought a new MacBook M1 and didn't realize that VirtualBox will not work on it.

And as per your policy statement, you can not let us know if there will be any update in the future to support the M1 chip or not. Very sad to know about it.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use