VirtualBox

Ticket #20175 (closed defect: fixed)

Opened 8 months ago

Last modified 5 months ago

EVE project (Linux Foundation)- A critical error has occurred while running the virtual machine => fixed in SVN/next maintenance

Reported by: dautovri Owned by:
Component: other Version: VirtualBox 6.1.18
Keywords: VM, Cc:
Guest type: other Host type: Mac OS X

Description

A critical error has occurred while running the virtual machine, test or normal workload is running on VM. EVE project is part of Linux Foundation Edge.

Device: MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)

VB: version 6.1.19 r142673

OS: macOS Big Sur 11.2 (20D64)

How to reproduce:

git clone https://github.com/lf-edge/eden.git
cd eden
make clean
make build-tests
eden config add default --devmodel VBox
eden setup
eden start
eden eve onboard
eden test tests/vnc -v debug

Attachments

Screen Shot 2021-02-09 at 11.46.17 AM.png Download (144.4 KB) - added by dautovri 8 months ago.
Image
Screen Shot 2021-02-09 at 12.54.58 PM.png Download (84.8 KB) - added by dautovri 8 months ago.
VM configs

Change History

Changed 8 months ago by dautovri

Image

Changed 8 months ago by dautovri

VM configs

comment:2 follow-up: ↓ 3 Changed 8 months ago by aeichner

There must be some steps missing, if I try to reproduce the issue the started VirtualBox VM ends up with no disk attached and fails to boot. Please provide the full steps required.

comment:3 in reply to: ↑ 2 Changed 8 months ago by dautovri

Replying to aeichner:

There must be some steps missing, if I try to reproduce the issue the started VirtualBox VM ends up with no disk attached and fails to boot. Please provide the full steps required.

Did you install docker?

comment:4 Changed 8 months ago by aeichner

Yes, docker is installed and running. I also installed the other dependencies like qemu, etc.

comment:5 Changed 8 months ago by dautovri

comment:6 Changed 8 months ago by aeichner

Got it working now (had to delete the VM and redo everything), and I'm able to reproduce the guru meditation, investigating.

comment:7 Changed 8 months ago by aeichner

  • Summary changed from EVE project (Linux Foundation)- A critical error has occurred while running the virtual machine to EVE project (Linux Foundation)- A critical error has occurred while running the virtual machine => fixed in SVN/next maintenance

Please try the latest 6.1 testbuild from here which should fix the issue. Make sure to disable SIP on the host because testbuilds are not notarized.

comment:8 Changed 8 months ago by dautovri

Thank you for your quick response! Just tested macOS version and all tests is passed. I would like to ask when this fix will reach release. We would like to announce to our users about Virtual Box support.

comment:9 Changed 8 months ago by aeichner

Sorry, we don't make release dates public in case we have to delay it when something important crops up right before the release. The only public dates are Oracle's Critical Patch Updates where the next one will be on 20th April 2021.

comment:10 Changed 8 months ago by dautovri

Is this bug fix will be in the next Oracle Critical Patch Update( 20th April 2021)?

comment:11 Changed 8 months ago by aeichner

Yes but there will be a release most certainly before the next Critical Patch Update having the fix included as well.

comment:12 Changed 8 months ago by dautovri

Ok, thank you for your fix again!

comment:13 Changed 5 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use