VirtualBox

Ticket #20092 (closed defect: duplicate)

Opened 12 months ago

Last modified 12 months ago

vboxsf (Guest Additions 6.1.16) fails to compile on CentOS 8 Stream (kernel 4.18.0-257)

Reported by: shumkar Owned by:
Component: shared folders Version: VirtualBox 6.1.16
Keywords: Cc:
Guest type: Linux Host type: Linux

Description

Hi.

This issue is similar to https://www.virtualbox.org/ticket/19112.

vboxsf.ko can not be compiled due to error "MS_REMOUNT undeclared".

I fixed it by removing the lines

 https://github.com/mdaniel/virtualbox-org-svn-vbox-trunk/blob/88de9c9135ffa2ff100ce64931417aa8144afa76/src/VBox/Additions/linux/sharedfolders/vfsmod.c#L48

and

 https://github.com/mdaniel/virtualbox-org-svn-vbox-trunk/blob/88de9c9135ffa2ff100ce64931417aa8144afa76/src/VBox/Additions/linux/sharedfolders/vfsmod.c#L50-L52

in /opt/VBoxGuestAdditions-6.1.16/src/vboxsf/vfsmod.c

and then running 'make' and 'make install' (in src folder).

Screenshot with the error will be attached.

Attachments

CentOS_VB_800x600.jpg Download (176.9 KB) - added by shumkar 12 months ago.
Screenshot with the error

Change History

Changed 12 months ago by shumkar

Screenshot with the error

comment:1 Changed 12 months ago by shumkar

A correction:

and then running 'make' and 'make install' (in src folder).

and then running 'make' and 'make install' (in src/vboxguest-6.1.16 folder).

comment:2 Changed 12 months ago by shumkar

I have just seen the ticket https://www.virtualbox.org/ticket/20091.

Evidently, this ticket is a duplicate of 20091.

Last edited 12 months ago by shumkar (previous) (diff)

comment:3 Changed 12 months ago by paulson

  • Status changed from new to closed
  • Resolution set to duplicate

Closing this as a duplicate of #20091, see there for the fix resolution details.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use