VirtualBox

Ticket #20073 (closed defect: worksforme)

Opened 8 months ago

Last modified 4 months ago

mount fails after vboximg-mount

Reported by: andre-at-cp67 Owned by:
Component: virtual disk Version: VirtualBox 6.1.16
Keywords: vboximg-mount Cc:
Guest type: all Host type: Linux

Description

after vboximg-mount -i uuid {mount-point}
mount fails with message "cannot mount m/vol0 read-only"

host is Linux Debian 10.6
VirtualBox 6.1.16r140961
guests: Debian (ext4) and Windows (NTFS)

Attachments

Ticket-20073-1-details.txt Download (1.8 KB) - added by andre-at-cp67 8 months ago.
commands and context details

Change History

Changed 8 months ago by andre-at-cp67

commands and context details

comment:1 Changed 7 months ago by paulson

$ vboximg-mount -i 9517fcf0-c5c9-4edf-8631-ca78e15b88ad m
$ sudo mount m/vol0 /mnt
mount: /mnt: cannot mount m/vol0 read-only.

In order for root to be able to access the FUSE mounted virtual disk image located at 'm' you need to supply either '--root' to the vboximg-mount command line or '-o allow_root'. It turns out that '--root' is currently ignored due to a regression but '-o allow_root' will allow root to be able read the FUSE mounted virtual disk image. Note that as per the FUSE man page you might need to edit /etc/fuse.conf to be able to supply '-o allow_root' as a regular user:

CONFIGURATION
       Some  options  regarding  mount  policy  can  be  set   in   the   file
       /etc/fuse.conf. Currently these options are:

       user_allow_other
              Allow non-root users to specify the  allow_other  or  allow_root
              mount options (see below).

comment:2 Changed 4 months ago by paulson

  • Status changed from new to closed
  • Resolution set to worksforme

The regression regarding the '--root' option being ignored has been addressed in VirtualBox 6.1.20. Otherwise things work here as expected for me.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use