VirtualBox

Opened 4 years ago

Last modified 3 years ago

#20052 new defect

Unable to start any VM since BigSur installation

Reported by: Raoul555 Owned by:
Component: other Version: VirtualBox 6.1.16
Keywords: macos Cc:
Guest type: other Host type: other

Description

Hi,

I has several VM running fine in virtualbox on my Mac.

Since, I've upgrade my os to Macos Big sur, I'm not able to run any of my VM. It fails with the error:

Échec de l'ouverture de session pour la machine virtuelle Samsung Galaxy S6.

The virtual machine 'Samsung Galaxy S6' has terminated unexpectedly during startup with exit code 1 (0x1).

Code d'erreur : NS_ERROR_FAILURE (0x80004005)
Composant : MachineWrap
Interface : IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}

I did try to change virtualbox network configuration, and also change network interface of my VM, with no success.

Even the creation of new VM fails with same error at first start up.

In logs, I can find only:

00:19:40.821687 nspr-3   Launched VM: 1750348368 pid: 856 (0x358) frontend: GUI/Qt name: Debian2
00:19:41.322953 Watcher  ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={85632c68-b5bb-4316-a900-5eb28d3413df} aComponent={MachineWrap} aText={The virtual machine 'Debian2' has terminated unexpectedly during startup with exit code 1 
(0x1)}, preserve=false aResultDetail=0

What's wrong?

Change History (7)

comment:1 by Raoul555, 4 years ago

No Oracle dev is interested to fixing my but that's make VirtualBox useless?

comment:2 by aeichner, 3 years ago

VirtualBox works on BigSur with SIP enabled, do you by chance have SIP disabled?

comment:3 by Ee, 3 years ago

I think this is the usual error for users trying to run VB on Big Sur with SIP disabled. I can confirm that with SIP enabled, everything works. With SIP disabled, I get the error described.

However, leaving SIP enabled is not an option for power users. And excluding power users from VB, macOS, and Big Sur seems equally a non-option. I strongly urge prioritization to treat this as a bug to get fixed.

comment:4 by Steffen Moser, 3 years ago

I can fully confirm this bug with VirtualBox 6.1.16 on macOS Big Sur 11.0.1. It occurs when SIP is disabled (by applying "csrutil disable" in Big Sur's recovery mode). Unfortunately, I need to disable SIP for various reasons. One is that a lot of legacy drivers (e.g. used in many Thunderbolt-to-Ethernet adapters) do only work in an environment without SIP. So currently I have to choose whether I want to have VirtualBox or LAN connectivity and there are several reboots required to switch from one feature to the other one.

I also found that starting VMs in headless mode works also when SIP is disabled. At the same time, I am not able to display them. Using RDP to connect to localhost is a workaround.

comment:5 by aeichner, 3 years ago

Everyone who needs to run VBox with SIP disabled please try the latest testbuild from here. It contains fixes for that configuration.

comment:6 by Ee, 3 years ago

I tried the test build on SIP disabled Big Sur. VirtualBox appears to be working.

comment:7 by Steffen Moser, 3 years ago

The test build solves the issue for me, too. Everything working fine in Big Sur, even with SIP disabled.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use