VirtualBox

Ticket #1991 (closed enhancement: fixed)

Opened 6 years ago

Last modified 5 years ago

Show 'banner' when in fullscreen

Reported by: markba Owned by:
Priority: minor Component: GUI
Version: VirtualBox 1.6.4 Keywords: fullscreen
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

When in fullscreen, there are a few problems:

  • not immediately clear that one is in fullscreen, i.e. using a virtual machine (especially novice users)
  • not clear what key to use to go to windowed mode and/or to display the vbox popup menu

Both problems can be solved by showing a banner on top of the screen, just like MSTSC (MS Terminal Server Client) does. This banner is always visible, but can be changed by the user to disappear in normal operation and to appear when hovering over the top section (auto-hide).

(sorry that I cannot a screenshot of this: the banner showed by MSTSC is considered by Windows as no part of the screen, thus not appear on a screenshot)

Change History

comment:1 Changed 6 years ago by frank

  • Description modified (diff)

Note that the users gets a big fat message box before he enters the fullscreen mode the first time. The message box explains how to get out of the mode.

The other problem you mentioned is not a bug but a feature for many people, i.e. sometimes one don't have to know that this isn't a real computer but a virtual machine.

comment:2 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Starting with VirtualBox 2.2.4 there is a mini toolbar which is automatically shown when the guest is in fullscreen or seamless mode.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use