VirtualBox

Ticket #19706 (closed defect: fixed)

Opened 5 months ago

Last modified 2 months ago

MacOS hosts no longer able to run VBoxHeadless as of 6.0.18 and 6.1.4 => fixed in svn/6.1.x x>12

Reported by: myshell Owned by: paulson
Component: guest control Version: VirtualBox 6.1.4
Keywords: Cc:
Guest type: all Host type: Mac OS X

Description (last modified by paulson) (diff)

It is impossible to launch a VM in headless mode because of a problem of setugid which is not allowed.

It works fine with VirtualBox 6.1.2 but not with the following versions.

The error message seen is:

$ /Applications/VirtualBox.app/Contents/MacOS/VBoxHeadless -s solaris Oracle VM VirtualBox Headless Interface 6.1.4 (C) 2008-2020 Oracle Corporation All rights reserved.

2020-07-24 09:40:25.798 VBoxHeadless[2026:18559] The application with bundle ID org.virtualbox.app.VirtualBox is running setugid(), which is not allowed.

Attachments

VBox.log Download (72.6 KB) - added by myshell 5 months ago.
VBox.log obtained following the VBoxHeadless command

Change History

comment:1 Changed 5 months ago by paulson

  • Status changed from new to awaitsfeedback

Can you provide further details about the issue you are seeing? Which method are you using to start your headless VM? The manual (https://www.virtualbox.org/manual/ch07.html) explains there are several ways to start a headless VM:

$ VBoxManage startvm VM-name --type headless

The --type option causes Oracle VM VirtualBox to use VBoxHeadless as the front-end to the internal virtualization engine, instead of the Qt front-end.

$ VBoxHeadless --startvm uuid|vmname

This way of starting the VM helps troubleshooting problems reported by VBoxManage startvm, because you can sometimes see more detailed error messages, especially for early failures before the VM execution is started. In normal situations VBoxManage startvm is preferred, since it runs the VM directly as a background process which has to be done explicitly when directly starting with VBoxHeadless. The full documentation of the command is in Section 7.3, “VBoxHeadless”.

Start VBoxHeadless from the VirtualBox Manager GUI, by pressing the Shift key when starting a virtual machine or by selecting Headless Start from the Machine menu.

I am able to launch a headless VM using VirtualBox 6.1.10 on Mojave using all of the above methods so there must be something different about your setup.

Can you try the 'VBoxHeadless' command above and include any error messages seen? Can you also attach a VBox.log from a failed instance to start the VM in headless mode?

Changed 5 months ago by myshell

VBox.log obtained following the VBoxHeadless command

comment:2 Changed 5 months ago by myshell

I tried the 3 ways, they all failed

$ VBoxHeadless -s Buster Oracle VM VirtualBox Headless Interface 6.1.10 (C) 2008-2020 Oracle Corporation All rights reserved.

2020-07-09 09:54:39.267 VBoxHeadless[28189:26305689] The application with bundle ID org.virtualbox.app.VirtualBox is running setugid(), which is not allowed.

comment:3 Changed 4 months ago by paulson

  • Owner set to paulson
  • Status changed from awaitsfeedback to accepted
  • Version changed from VirtualBox 6.1.10 to VirtualBox 6.1.4
  • Description modified (diff)
  • Summary changed from MacOS Mojave and VboxHeadless to MacOS hosts no longer able to run VBoxHeadless as of 6.0.18 and 6.1.4

This is related to the VirtualBox hardened runtime which I didn't run into since this Mac system has System Integrity Protection (SIP) disabled. Once I re-enabled SIP I was able to reproduce the problem and have a fix in progress. This issue was introduced in VirtualBox 6.0.18 and 6.1.4.

comment:4 Changed 4 months ago by paulson

  • Summary changed from MacOS hosts no longer able to run VBoxHeadless as of 6.0.18 and 6.1.4 to MacOS hosts no longer able to run VBoxHeadless as of 6.0.18 and 6.1.4 => fixed in svn/6.1.x x>12

This has been addressed in revision r139544 of the development branch of VirtualBox and is available now in the development snapshot Testbuilds. The fix has also been backported to the 6.1 branch of VirtualBox as of revision r139010 and is available now in the 6.1.x Testbuilds. The fix will also be part of the next maintenance release of VirtualBox 6.1.x.

comment:5 Changed 2 months ago by aeichner

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use