VirtualBox

Ticket #1968 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Robotic "broken" sound – external sound

Reported by: jocabola Owned by:
Priority: major Component: audio
Version: VirtualBox 1.6.4 Keywords: deiver
Cc: Guest type: Windows
Host type: Mac OS X

Description

Hello,

Sound is no longer working properly since I installed an external FireWire M-Audio Soundcard in my laptop. The virtual sound card is still recognized as before but the sound is kind of "robotic" and broken.

I am using the standard settings CoreAudio + ICH AC97 Driver. Other settings don't work at all. If I disconnect my external soundcard, the standard settings work properly again through the macbook's internal soundcard.

This gives me an idea of a feature request: For users with multiple sound cards, could we choose the target soundcard to be used by the Virtual machine? That would be great!

This bug was already on previous versions and not yet corrected by the latest 1.6.4 build.

Many Thanks, Eduard

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by eskild

I can confirm this problem 100%, but with a t.c. electronic Konnekt 24D device. To me it sounds like the samplerate is all messed up. FWIW, I'm running the t.c. at 48kHz, but I don't know if changing it would give good sound. Problem is, for all my other stuff, I need the soundcard to run at 48kHz, so it's not a permanent solution.

Please fix this; it forces me to boot my noisy XP box when for some sound apps.

Thanks.

comment:2 in reply to: ↑ 1 Changed 5 years ago by eskild

Oh, and this is on VB 2.2.2.

comment:3 Changed 5 years ago by jocabola

Problem persists for me too. I have tried 44.1, 48 and 96 Khz in my M-Audio but nothing helps.

Please fix that.

Thaks a lot,

comment:4 Changed 5 years ago by haravikk

I'm getting this as well, with Windows XP Pro SP3 if that makes any difference? I don't have any other guest OSes to try except for Windows 7 which doesn't sound like it works.

I have a Griffin FireWave external (Firewire) sound-card.

comment:5 Changed 5 years ago by jocabola

The problem is the same in all guests I have tried so far: Windows XP, Vista, Windows 7 and Ubuntu.

I don't think this is a guest-related problem at all.

Best,

comment:6 follow-up: ↓ 7 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 3.2.10 please.

comment:7 in reply to: ↑ 6 Changed 4 years ago by eskild

After a quick test: Fix is verified for 3.2.10 with Leopard 10.5.8. I'll do more testing shortly, but it looks very promising.

Thank you *so* much! :-)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use