VirtualBox

Opened 4 years ago

Last modified 3 years ago

#19640 assigned defect

Linux Fullscreen Guest display broken

Reported by: Feline Owned by: gombara
Component: guest additions/x11/graphics Version: VirtualBox 6.1.10
Keywords: Linux guest fullscreen Cc:
Guest type: Linux Host type: Linux

Description

At VirtualBox 6.1.4, the login screen shows fullscreen and once logged in, the desktop is set to fullscreen - in my case 1280 x 1024.

Since VirtualBox 6.1.6 all my Debian 10 guests that run fullscreen have had their display go blank once you've logged in.

The same problem still exists with VirtualBox 6.1.10. The login screen is reduced to 800 x 600 and once logged in, the guests screen goes blank. If you use the View -> Set Fullscreen (or Host+F key), the guests screen reappears as windowed. Do this again and the guests display is fullscreen again. However, rebooting the guest results in the same blank screen again.

Attached are two VBoxLogs, one from 6.1.10 which is taken at the point the guests screen has gone blank and the other when using the GA's from 6.1.4, when everything works as it should.

The Host is running Debian 10 with the Mate desktop. The affected guest(s) are also running Debian 10 with the Mate desktop.

Attachments (2)

VBoxLog_FScreenBroken.zip (19.2 KB ) - added by Feline 4 years ago.
VBoxLog_FScreenWorking.zip (19.2 KB ) - added by Feline 4 years ago.

Download all attachments as: .zip

Change History (9)

by Feline, 4 years ago

Attachment: VBoxLog_FScreenBroken.zip added

by Feline, 4 years ago

Attachment: VBoxLog_FScreenWorking.zip added

comment:1 by gombara, 3 years ago

Owner: set to gombara
Status: newassigned

comment:2 by Em444, 3 years ago

Kind of similar issue .

in full screen , i have issue just after login , and my session is frozen waiting for /usr/lib/gnome-session/gnome-session-check-accelerated to finish .

comment:3 by Feline, 3 years ago

Sadly still not fixed in 6.1.12

comment:4 by Koen027, 3 years ago

Also experiencing something like this on Windows10, with Ubuntu 18.04.4, 64 bit guest. And Debian 10, 64 bit.

The only thing I can get working is a prebuilt Ubuntu server VM from osboxes. Haven't tried Debian Server prebuilt.

Everything else just doesn't work, in terms of graphics.

My CPU is an AMD 2700X and graphics is also AMD, Radeon version 20.7.2, latest version, at time of writing.

comment:5 by AlbertoZGZ, 3 years ago

Confirmed in 6.1.12 on Ubuntu 16.04 host (After an upgrade from 6.0, that worked fine)

comment:6 by Feline, 3 years ago

Problem still exists in Virtualbox 6.1.16 There was a changelog item which seemed to reference this error but it only related to 32-bit guests - all my affected guests are 64-bit.

comment:7 by nixuser, 3 years ago

This is an issue that has phased in and out for years. Currently I have this on RHEL, CentOS, Oracle and Fedora. A fix on those distros is to set the display mode from the preferred VMSVGA mode to the deprecated VBoxSVGA mode. In VMSVGA mode I log in to a black screen (from 800x600 greeter) and have to hit Host-key-F twice to bring it back. VBoxSVGA mode fixes it for now. This probalem has existed on-and-off for many years.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use