VirtualBox

Opened 4 years ago

Closed 16 months ago

#19620 closed defect (fixed)

Host-Only Ethernet Adapter DHCP, guest os can not get IP when resume

Reported by: MaxChen Owned by:
Component: other Version: VirtualBox 6.1.8
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

I suspend the host, after a few hours, I resume the host. Then I would find that the guest do not get the correct IP by dhcp

The system works fine when I am using VB 6.0.14, I upgrade VB to 6.1.8 this morning, and encounter this bug .

Attachments (1)

VBox.log (100.2 KB ) - added by MaxChen 4 years ago.
log file

Download all attachments as: .zip

Change History (5)

by MaxChen, 4 years ago

Attachment: VBox.log added

log file

comment:1 by MaxChen, 4 years ago

NOT be fixed in 6.1.10 yet

Last edited 4 years ago by MaxChen (previous) (diff)

comment:2 by Vimu, 3 years ago

I do have similar issue since I updated to VB 6.1.X. (currently running 6.1.14) But I do use bridged networking and my host is Windows 10, the guests are Windows 7 and CentOs 7 (opposite setup of MaxChen).

For both guests I tried this:

Resetting guest's network does not help. Rebooting the guests does not help. Deactivating and activating host's network adapter does not help.

What helps currently (on my machine): Suspend both guests (save state of virtual machine) and reboot the host. As soon as the guests are resumed from saved state their network receives an ip address.

Last edited 3 years ago by Vimu (previous) (diff)

comment:3 by janitor, 3 years ago

This is likely fixed in SVN and will be in the next test build (r141267 or later).

comment:4 by aeichner, 16 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use