VirtualBox

Ticket #1952 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Starting a VM turns DPMS off in X.

Reported by: dimitris Owned by:
Priority: minor Component: GUI
Version: VirtualBox 1.6.4 Keywords: screen saver
Cc: Guest type: Windows
Host type: Linux

Description

This is in VB-OSE 1.6.2, Debian sid package (1.6.2-dfsg-4).

Before a VM starts, xset q says:

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 600
  DPMS is Enabled
  Monitor is On

Once the VM is started:

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 600
  DPMS is Disabled

This is the same whether the VM starts (was last stopped) in seamless mode or not.

Then once the VM is stopped, DPMS comes back. I can also re-enable it manually after the VM starts, so this is only an issue when I forget and the screen stays on without reason.

Attachments

VBox.log Download (28.6 KB) - added by dimitris 6 years ago.
log of a VM being started then switched to seamless mode.

Change History

Changed 6 years ago by dimitris

log of a VM being started then switched to seamless mode.

comment:1 Changed 6 years ago by dimitris

Oops, forgot to set the version to 1.6.2. Sorry about that.

comment:2 Changed 6 years ago by frank

Confirmed. This is a problem of the SDL library we use for our GUI. The SDL subsystem turns the screen saver off as long as it is active. Setting the environment variable SDL_VIDEO_ALLOW_SCREENSAVER to 1 will fix this problem for Linux (and probably for Windows) hosts. However, there is at least one known bug in the Debian libSDL which prevents this fix from working. Debian patches libSDL to evaluate this variable too late (see  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=458813). The result is that the screen saver is stopped but not activated after VirtualBox has finished (a worse behavior).

We will try to workaround this problem in future releases.

comment:3 Changed 5 years ago by dimitris

Looks like this  has been fixed, and indeed VB 2.0.4 on my Debian unstable host with libsdl 1.2.13-4 no longer has this problem.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use