VirtualBox

Ticket #19314 (awaitsfeedback defect)

Opened 20 months ago

Last modified 2 months ago

Copy & paste patially broken in 6.1.2

Reported by: Megabreit Owned by:
Component: clipboard Version: VirtualBox 6.1.2
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Host OS is Windows 8 Guest OS is Ubuntu 18.04 Other platforms not tested.

I upgraded from 6.0.14 to 6.1.2. Matching guest additions are also installed. In Ubuntu the included guest toos are installed: virtualbox-guest-dkms 5.2.34-dfsg-0~ubuntu18.04.1 Copy & Paste was working fine with 6.0.14 in both directions and I could copy & paste "larger amounts" of text characters. A few tens or hundred lines worked fine. With 6.1.2 I can only copy & paste very view lines, about 4 to 8, depending on their length. This applies to both directions. When the contents becomes to large, the paste target "remembers" the last clipboard content and pastes it instead.

No log currently available.

Attachments

vbox-6.1.2.log Download (165.8 KB) - added by Megabreit 20 months ago.
Vbox log of 6.1.2

Change History

comment:1 Changed 20 months ago by fbatschu

if you have installed Virtualbox version 6.1.2 you should upgrade the guest additions also to that level, still running virtualbox-guest-dkms 5.2.34-dfsg-0~ubuntu18.04.1 is certainly a bit very outdated.

can you please clarify what you actually have installed here?

comment:2 Changed 20 months ago by fbatschu

  • Status changed from new to awaitsfeedback

Changed 20 months ago by Megabreit

Vbox log of 6.1.2

comment:3 Changed 20 months ago by Megabreit

I found the old log of the previous installation and attached it.

As described in the ticket I used a "default" Ubuntu 18.04 installation with most current patch level. The current Ubuntu LTS includes 5.2.34 only.

The problem does not appear with exactly the same VM in 6.0.14/16 and the older virtualbox-guest-dkms 5.2.34. Therefore I doubt that having newer versions will fix it.

comment:4 Changed 19 months ago by Megabreit

I reinstalled 6.1.4 today and something seems to have changed. Copy and paste from the Linux VM to the Windows host seems to work now... at least for normal amounts of data... 1 page of text.

Copy and Paste back is still broken. But differently. When the text contains rich text, it always doesn't work. Same thing works with 6.0.18. Normal text can be copied, but there is still an unknown smaller size limit.

The environment has changed slightly. The host is running Windows 10 now. Everything else is still the same. I'll upload a new log when necessary.

I went (again) back to 6.0.18 to be able to do work ;-)

comment:5 Changed 18 months ago by krthie

I had problems with copy-paste between Ubuntu 18.04-guest and Windows10 home from 6.1.x as well. i just installed 6.1.6 and this currently works. (early days though)

comment:6 Changed 17 months ago by Megabreit

I tried 6.1.6 today in the same environment (Windows 10 host and Ubuntu 18.04 client) and it's still broken. Nothing changed from 6.1.4, see my last comment:4.

comment:7 Changed 11 months ago by Luca

Hi, I am using 6.1.12, and I am experiencing the same issue. On my machine it seems that the limit is 510 characters: if I copy and paste 510 characters it works, 511 does not.

Please fix it and add a unit test to verify that it is possible to copy and paste much larger amounts of text.

comment:8 Changed 6 months ago by asdfafds

Same problem here. Copying 510 chars work, 511 just empties the clipboard. Tested using bidirectional clipboard.

VirtualBox: Versión 6.1.12 r139181 (Qt5.6.2)
Guest Additions: 5.2.8_KernelUbuntu r120774
Host: Windows 10 Enterprise. 64 bits.
Guest: Ubuntu 18.04.5 LTS. 64 bits. (4.15.0-135-generic)

comment:9 Changed 2 months ago by Robert B

I can confirm that in the latest version of VirtualBox this problem is still present, with the same limit of 510 characters, Windows host, Linux guest.

Interestingly, copying from Linux guest to Windows host does not seem to have any limit, even for thousands of lines of text.

VirtualBox 6.1.22 r144080 (Qt5.6.2)
Guest Additions: 5.2.42_Ubuntu r137960
Host: Windows 10 Enterprise 1909 1863.1646 (64 bits)
Guest: Ubuntu 18.04.5 LTS (64 bits) (4.15.0-151-generic)

This is very annoying as copying larger pieces of text is not possible. Instead of

(Host)
  Copy from source application

(Guest)
  Paste in target application

it requires

(Host)
  Copy from source application
  Open editor
  Paste
  Save file

(Guest)
  Open editor
  Open file
  Select all
  Copy
  Paste in target application

Please fix this.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use