VirtualBox

Ticket #1926 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Linux guest, Mac OS X host: mouse wheel does not work as expected

Reported by: elentirmo Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

VirtualBox 1.6.4

Host: Mac OS X 10.5.1

Guest: Ubuntu Hardy (8.04), using guest additions 1.6.4

In Ubuntu Hardy guests, the scroll wheel performs vertical scrolling when I rotate the scroll wheel slowly, and horizontal scrolling when I rotate it more quickly. By setting the scrolling speed to Slow in Mac OS X System Settings -> Keyboard & Mouse, the scrolling works as expected, however the scrolling is now too slow in my host applications :-)

Mac OS X uses "accelerating scrolling": when you keep scolling, eventually the actual scrolling will speed up. It seems that Mac OS sends different scroll events when scrolling faster.

On the forums a similar problem was discussed, without a resolution:  http://forums.virtualbox.org/viewtopic.php?t=8352&highlight=scroll

Change History

comment:1 Changed 6 years ago by dwt

I can reproduce this with a guest of Ubuntu Hardy (8.04) and the guest additions 1.6.4.

Also someone in the Forums could reduce this to only happen after installing the guest additions, so this is probably where the bug is.

comment:2 Changed 5 years ago by elentirmo

Still present in 2.2.0.

comment:3 Changed 5 years ago by davenorth

I'm not sure this is a VirtualBox problem so much as an xorg/ubuntu issue. If you check your /etc/X11/xorg.conf I think you'll find the InputDevice section for the mouse does not include the specific option "ZAxisMapping" "4 5" directive. (If, indeed, there is such a section). If you add it, the problem should go away (and xev should show all "up" scrolls as "button 4" and all "down" scrolls as "button 5".

Without it, you'll see "button 4" break to "button 6", probably as a result of the garbled signal os x sends for "accelerated scroll." With it, the behavior disappeared, at least on Debian Lenny. The same should probably apply to Ubuntu, and I'd be interested to know otherwise.

To clarify, it should look something like this:

Section "InputDevice"

Identifier "Configured Mouse" Driver "vboxmouse" Option "CorePointer" Option "ZAxisMapping" "4 5" <-- Add This Line

EndSection

comment:4 Changed 5 years ago by elentirmo

Hi Dave,

The InputDevice section you supplied seems to have fixed the issue for me. Thanks!

Roel

comment:5 Changed 5 years ago by dwt

Sorry, I can't reproduce this anymore on 2.1.4 and Ubuntu Intrepid Ibex - so sadly I can't verify the fix.

comment:6 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to fixed

Seems to be fixed. Reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use