VirtualBox

Ticket #19225 (closed defect: fixed)

Opened 5 weeks ago

Last modified 4 weeks ago

"NEWEST" Extension Pack 6.1.2 Install Failure (01-15-20)

Reported by: jwhite711 Owned by:
Component: other Version: VirtualBox 6.1.0
Keywords: VirtualBox 6.1.2, Extension Pack 6.1.2, Update error, freeze, solutions, ideas, resolutions, work around, integration, innovation, common issues, install, failure Cc: johnwhite71@…
Guest type: OSX Server Host type: Windows

Description

I just updated to the recent version of VirtualBox 6.1.2-135662-Win. Required update for the Extension Pack 6.1.2 install seems to never install.

Even after a half hour or more waiting? It just continues saying that it is installing, and nothing seems to happen.

  1. Is this a common error, or simply a bug within the new version?
  1. Should a complete uninstall be done before installing the new version, as opposed to simply upgrading?
  1. When will this issue be fixed, or is there a workaround?
  1. What are the new additions or benefits to the most recent version in comparison to the previous? Is it even worth the update, or needed?
  1. What exactly is the point of updating unless specific common problems have been resolved?

For example:

  • Having the app work flawlessly, and easily with macOS Software, and Hardware format?
  • Fixing the common Audio problems? Common screen problems? Drag and Drop, Bidirectional, etc.? Acknowledging any common, well known issues discussed by the community, or simply searching online and seeing an endless list.
  • The ability to also work with .dmg, or .cdr, in addition to .iso, etc.?

Finally, I have only been using this product for about 3 weeks, and have ran into many common problems that everyone has had at one time or another. It puzzles me that there have been many who have the intelligence to provide fixes, or even workarounds to all of these common issues, yet, your development team still hasn't even addressed them, or came up with their own fixes.

Therefore, if not fixing these common issues, or offering the ability to integrate the many features i or others have ran into, and mentioned just in the time i have been using it, or combining innovative ideas that may not have been discussed, why even attempt the update?

Though this is open source, and freely offered, does it mean that less effort is involved, or care into becoming the best at its field? Not an accusation, but generally speaking. Thank you for the opportunity. Either way...With all the issues, or common errors i have mentioned, there have been some very intelligent, and proficient users who have come up with solutions. Why not integrate their brilliant, innovative resolutions?

Change History

comment:1 Changed 5 weeks ago by infieldg

Ditto, installing automatically after the upgrade it got to 100% then had a 'network error' (twice) so I downloaded "Oracle_VM_VirtualBox_Extension_Pack-6.1.2.vbox-extpack" and yeah it's STILL "installing", never going to finish, rebooted, no hyper-v, same again, "Installing extension pack..." and the green progress blur cycling forever. It can't be stopped, it won't response, have to end-task.

Windows 10 Pro, version 10.0.18362 build 18362 on Core i7-8750H

Last edited 5 weeks ago by infieldg (previous) (diff)

comment:2 Changed 5 weeks ago by quizerti

I am also having this issue with Windows 10 18353.592 x64. Seems that a lot of other people are having the same issue.

comment:3 Changed 5 weeks ago by scottgus1

Running into the same problem. Windows 10 1809 build 17763.914, Virtualbox 6.1.2, EP 6.1.2: The "Installing Extension Pack" green rolling progress bar still rolling after 20 minutes.

What troubleshooting data can be provided?

comment:4 Changed 5 weeks ago by scottgus1

I have just noticed that the files within the EP download are in the Virtualbox EP folder, just that the progress bar doesn't go away.

I rebooted the PC and Virtualbox opened up with the EP installed, and a guest with the VRDP server started, and I was able to RDP into it, so it appears the EP is working.

comment:5 Changed 5 weeks ago by Sethaniel

I was able to get the extension pack to install by doing the following (not sure all steps are neccessary, but it's what I did):

  1. Download the extension manually and place it on the root of my C drive
  2. Start VirtualBox by right clicking icon and selecting Run As Administrator
  3. Go to File > Preferences > Extensions and select add extension, picking the extension file I had downloaded
  4. Let it run for a while (3 or 4 minutes)
  5. Using the task manager, go to the details tab and find the VirtualBox Extension helper process (I forget the exact name but something like VBoxExtensionHelper). I right clicked it and selected end process tree.
  6. Close VirtualBox
  7. wait for all VBox processes to die down by looking int he detail tab of the task manager
  8. Restart VirtualBox normally (not using run as admin)

I was then able to install guest additions in my guest VM and it seems to be working as expected.

comment:6 Changed 5 weeks ago by gruber

Same bug windows 7 stuck on green progress and never finish

Last edited 5 weeks ago by gruber (previous) (diff)

comment:7 Changed 5 weeks ago by JMH1

This occurs for both new installs and upgrade installs.

comment:8 Changed 5 weeks ago by ArtZ

Tried all methods above - same error cannot get EP 6.1.2 to install at all

comment:9 Changed 5 weeks ago by iuchenik

Got it installed by using VB 6.1.0:

  • Rolled back VB installation to VB 6.1.0;
  • Uninstalled EP 6.1.0;
  • Installed (previously downloaded) EP 6.1.2 (success);
  • Upgraded VB to (installed) VB 6.1.2.

VB 6.1.2 with EP 6.1.2 work with Linux Mint 19.3.

comment:10 Changed 5 weeks ago by quizerti

This problem now seem to be fixed in 6.1.2-135663.

comment:11 follow-ups: ↓ 12 ↓ 14 Changed 5 weeks ago by scottgus1

Confirmed, 6.1.2-135663 installs the EP correctly, with no failures.

comment:12 in reply to: ↑ 11 Changed 5 weeks ago by John Neely

Replying to scottgus1:

Confirmed, 6.1.2-135663 installs the EP correctly, with no failures.

Where did you get 6.1.2-135663? The one that I get to download is 6.1.2-135662.

Thanks.

comment:13 Changed 5 weeks ago by John Neely

Where did you get 6.1.2-135663? The one that I get to download is 6.1.2-135662.

Thanks.

comment:14 in reply to: ↑ 11 ; follow-up: ↓ 18 Changed 5 weeks ago by michal.mulawa

Replying to scottgus1:

Confirmed, 6.1.2-135663 installs the EP correctly, with no failures.

this also worked for me. 135663 is currently the one available on download page https://www.virtualbox.org/wiki/Downloads

comment:15 Changed 5 weeks ago by clahor

hello for me it doesn't run with windows 10 v 1909

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe extpack install  --replace "E:\download-datas\Oracle_VM_VirtualBox_Extension_Pack-6.1.2-135662.vbox-extpack"
VirtualBox Extension Pack Personal Use and Evaluation License (PUEL)


...

1 SUBJECT OF AGREEMENT....

2 GRANT OF LICENSE. ...

Oracle reserves all rights not expressly granted in this license.

3 RESTRICTIONS AND RESERVATION OF RIGHTS.

...

4 TERMINATION. ...

5 DISCLAIMER OF WARRANTY....

6 LIMITATION OF LIABILITY. ...

7 SEPARATELY LICENSED THIRD PARTY TECHNOLOGY. ...

8 EXPORT. ...

9 U.S. GOVERNMENT END USERS. Oracle programs, ...

10 MISCELLANEOUS. ...

Do you agree to these license terms and conditions (y/n)? y

License accepted. For batch installation add
--accept-license=56be48f923303c8cababb0bb4c478284b688ed23f16d775d729b89a2e8e5f9eb
to the VBoxManage command line.

0%...

do you have any advice???

Last edited 5 weeks ago by clahor (previous) (diff)

comment:16 Changed 5 weeks ago by klaus

You need to download and install the updated 6.1.2 release for Windows (mind the change in the filename, it has revision 135663 now), from  https://download.virtualbox.org/virtualbox/6.1.2/VirtualBox-6.1.2-135663-Win.exe

This will cure the extension pack install issues.

comment:17 Changed 5 weeks ago by klaus

To recover from the hang, kill the two VBoxExtPackHelperApp.exe processes you can see in the task manager.

comment:18 in reply to: ↑ 14 Changed 5 weeks ago by wilburx3

Replying to michal.mulawa:

Replying to scottgus1:

Confirmed, 6.1.2-135663 installs the EP correctly, with no failures.

this also worked for me. 135663 is currently the one available on download page https://www.virtualbox.org/wiki/Downloads

EDIT - see this is only for WIN hosts. Sorry.

I get VirtualBox-6.1.2-135662-OSX.dmg when I download from that link.

I do not see it in here  https://download.virtualbox.org/virtualbox/6.1.2/ either.

Last edited 5 weeks ago by wilburx3 (previous) (diff)

comment:19 Changed 5 weeks ago by clahor

You need to download and install the updated 6.1.2 release for Windows (mind the change in the filename, it has revision 135663 now

thx good job it runs

comment:20 Changed 4 weeks ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use