VirtualBox

Ticket #19188 (closed defect: fixed)

Opened 11 months ago

Last modified 9 months ago

Mac OSX 10.15.2 guest freezes on startup

Reported by: danrb Owned by:
Component: other Version: VirtualBox 6.1.0
Keywords: Mac OSX Catalina 10.15.2 guest Cc:
Guest type: other Host type: Mac OS X

Description

Mac OSX 10.15.2 as a guest freezes when you try to start it or complete an upgrade from a previous version (combo update or app store update) using VirtualBox 6.1.0 or 6.1.1. Mac OSX 10.15.1 works well as a guest with VirtualBox 6.1.0 (release build) or 6.1.1 (development build). Would it be possible to implement compatibility for Mac OSX 10.15.2 guests in VirtualBox? Many thanks, Dan

Attachments

Screenshot 2020-01-25 at 14.29.32.png Download (258.2 KB) - added by Jaanus 10 months ago.
VBoxSVC.log Download (40.5 KB) - added by Jaanus 10 months ago.
VBoxSVC.log.1 Download (3.1 KB) - added by Jaanus 10 months ago.
runMacOSVirtualbox.log Download (3.8 KB) - added by Jaanus 10 months ago.
VBoxLogs.zip Download (90.3 KB) - added by Jaanus 10 months ago.
VBox.log Download (158.4 KB) - added by Vietwoojagig2 10 months ago.
Tried to update from 10.15.1 to 10.15.3 in 6.1.12

Change History

comment:1 Changed 11 months ago by Vietwoojagig2

VirtualBox 6.1.2 does not solve the problem.

comment:2 Changed 10 months ago by aeichner

We need at least a VBox.log from the affected VM to start looking into this issue.

Changed 10 months ago by Jaanus

Changed 10 months ago by Jaanus

Changed 10 months ago by Jaanus

Changed 10 months ago by Jaanus

comment:3 Changed 10 months ago by Jaanus

I attached a number of logs and screenshots. This bug is fully reproducible for me using this script:  https://github.com/AlexanderWillner/runMacOSinVirtualBox I attempt a clean install with the script, and end up with the result described in this bug. My related report in Github:  https://github.com/AlexanderWillner/runMacOSinVirtualBox/issues/95

comment:4 Changed 10 months ago by aeichner

We need a VBox.log of the affected VM. You attached the VBoxSVC.log which is of no use for this particular issue unfortunately. The VBox.log can be usually found in ~/VirtualBoxVMs/<VM name>/Logs.

comment:5 Changed 10 months ago by Jack_Smith

This appears to be reproducible in all versions of VirtualBox on all macOS 10.15.2 guests. A workaround involves using the "boot.efi" file from an earlier version of macOS.

Changed 10 months ago by Jaanus

comment:6 Changed 10 months ago by Jaanus

Attached VBox.log files for the affected VM.

Last edited 10 months ago by Jaanus (previous) (diff)

Changed 10 months ago by Vietwoojagig2

Tried to update from 10.15.1 to 10.15.3 in 6.1.12

comment:7 Changed 10 months ago by Vietwoojagig2

Also does not work with to update 10.15.3 from 10.15.1 in 6.1.2

comment:8 Changed 10 months ago by michaln

The source of the boot hangs has been identified, although fixing it correctly isn't entirely trivial. It's triggered by a very, very old problem in VirtualBox. Apple switches to 32-bit mode (i.e. out of long mode) with junk in the high byte of RDI register and expects that when it switches back to long mode, the junk will be zeroed out because the EDI register was written in 32-bit mode. That is relying on processor behavior which is not documented, or rather behavior that is explicitly undocumented. Neither Intel nor AMD say what should happen in this case, although the behavior of actual CPUs appears to be consistent.

At any rate it will be fixed for the next maintenance release.

comment:9 Changed 9 months ago by Vietwoojagig2

Was able to update to 10.15.3 with 6.1.4. It seems they solved the problem.

comment:10 Changed 9 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

Indeed, this was fixed for 6.1.4, thanks for confirming!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use