VirtualBox

Ticket #19160 (closed defect: fixed)

Opened 5 months ago

Last modified 4 months ago

VirtualBox 6.1 cannot use old VMs with disc encryption => fixed in 6.1.2

Reported by: torafu Owned by:
Component: virtual disk Version: VirtualBox 6.1.0
Keywords: encryption Cc:
Guest type: Linux Host type: Windows

Description

I have used disc encryption with my VMs (Windows host, Linux guests), latest ones created with 6.0.14, and some older. When I upgraded to VirtualBox 6.1 (including extension pack), booted the host machine(just to be safe), and tried to run the old VMs they did not anymore ask for disc encryption password, but instead the VM just tried to boot and failed with "No bootable medium found".

Luckily uninstalling 6.1 and installing 6.0.14 (and it's extension pack) worked, and I can again run my VMs.

Change History

comment:1 Changed 5 months ago by bladesong

I'll add to this as I have hit this particular issue also. Host Machine : Windows 10

Previously running 6.0.14 using a VM image encrypted via VirtualBox with no issues. Installed 6.1 over the top and now if I try to run the image I get the "No bootable medium found" error. My other image is not encrypted and it runs fine.

Steps taken (all via the VirtualBox GUI):

  • Unecrypted the VM image using v6.1, the image now runs correctly.
  • Encypted the image with v6.1, the image fails to run, with the "No bootable medium found" error occuring.
  • Unecrypt the image again, the image runs correctly again.

If there is anything else you want to to try let me know.

comment:2 Changed 5 months ago by bladesong

To add further to this.

I just loaded up a different image I had that was encrypted via 6.0.12. It works as expected. VirtualBox 6.1 asked me for the encryption password and the image loaded up correctly.

The image that still doesn't work if it is encrypted (see previous comment) is a debian based OS image, perhaps that makes a difference?

comment:3 Changed 5 months ago by geov

Also sometimes it works until first snapshot.

comment:4 Changed 4 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VirtualBox 6.1 cannot use old VMs with disc encryption to VirtualBox 6.1 cannot use old VMs with disc encryption => fixed in 6.1.2

This should be fixed with 6.1.2. The issue would appear as soon as there was a snapshot involved. Please try with 6.1.2 and reopen if this is still an issue and attach at least a VBox.log of the affected VM.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use