VirtualBox

Opened 5 years ago

Last modified 6 months ago

#19043 new defect

XWayland breaks mouse behavior on Linux/Wayland Hosts

Reported by: Cortex Owned by:
Component: other Version: VirtualBox 6.0.14
Keywords: mouse usb clicks Xwayland Cc:
Guest type: other Host type: Linux

Description

On Arch Linux (5.3.7-arch1-1-ARCH), recent as of 2019/10/23 mouse behaviour is broken on a windows 10 host. First mouse click in the guest (on an icon, however not at the background image) introduces this behaviour. Afterwards mouse clicks in guest and host system are not properly recognized anymore (on guest, GNOME seams to work correctly, however firefox, chromium, VirtualBox Manager and others don't). Keyboard function is correct. As soon as the guest is powered off, mouse behaviour is normal in the host.

Changing mouse settings from PS/2 to tablet mode does not change the behaviour.

I could track the error down to the upgrade of usbutils-010 to usbutils-012. Downgrading usbutils to 010 solved the error

The log of the session is attached.

Attachments (1)

Windows10-2019-10-23-09-48-58.log (137.8 KB ) - added by Cortex 5 years ago.
Log of Session

Download all attachments as: .zip

Change History (18)

by Cortex, 5 years ago

Log of Session

comment:1 by Cortex, 5 years ago

Just to add: the problem re-appears (despit having usbutils-010) installed when the host is configured to 2 monitors. No matter whether 2d & 3d hardware acceleration are used and in Both VGA and SVGA mode.

comment:2 by Cortex, 5 years ago

Another Addition: Checking 3d acceleration (switching it on) also brought the error back - even with only 1 monitor.

Version 0, edited 5 years ago by Cortex (next)

comment:3 by Cortex, 5 years ago

Even after the downgrade of usbutils the problem re-occured after some time (1-2 h). In turn it had again been constantly present. Overall the occurrence of the problem seems highly erratic to me.

comment:4 by Cortex, 5 years ago

Ok, finally I could track the problem down. Deactivating Wayland leads to expected behaviour.

So there is a problem with the interaction between VirtualBox and xwayland.

comment:6 by Socratis, 5 years ago

So, should I change the title from "usbutils 012 breaks mouse on Linux" to something like "xwayland breaks mouse behavior" or something similar?

If you could edit the ticket's title, what would you change it to?

comment:7 by Socratis, 5 years ago

Component: USBother
Summary: usbutils 012 breaks mouse on LinuxXWayland breaks mouse behavior on Arch Host

Based on the discussion in the forums (https://forums.virtualbox.org/viewtopic.php?f=7&t=95290#p463227) changing the title...

comment:8 by mmikk, 4 years ago

The issue still exists in 6.1.6 @ Wayland Ubuntu 20.04.

Until guests tools are started on guest OS (Windows 10) everything works fine. But after some operations (for example starting firefox with some sites - I could not track which yet) mouse clicks are lost in BOTH the guest OS and the host OS (the cursor image in the host OS is frozen to the shape of Guest OS cursor image). The issue remains until Guest OS is turned off.

When switched from Wayland to X11 the issue does not occur.

comment:9 by mmikk, 4 years ago

Also please update the title to: ...mouse behavior on Linux/Wayland Host - as multiple distros are affected and multiple versions of the virtual box have the issue unfixed.

comment:10 by Frank Batschulat (Oracle), 4 years ago

Keywords: Xwayland added
Summary: XWayland breaks mouse behavior on Arch HostXWayland breaks mouse behavior on Linux/Wayland Hosts

comment:11 by mmikk, 4 years ago

Are there some actions I could do that could help diagnose where the issue comes from? Please also update the version of the Virtual Box to 6.1.6 as this issue reproduces in this version.

comment:12 by jce, 3 years ago

I still see the same issue with VirtualBox v6.1.28.

comment:13 by mmikk, 3 years ago

Confirm, VirtualBox is unusable on Wayland. When X11 server eventually goes away, VirtualBox won't work on Linux at all.

comment:14 by GnomeUser, 3 years ago

I didn't see this issue often in the past but now with the upgrade to 6.1.30 it happens all the time. Something have changed between 6.1.26 and 6.1.30. Following the recommendation from #20355 I've turned off automatic keyboard capture under "File->Preferences" and it seems to solve the issue, but with it turned off it doesn't let me close windows inside VM with Alt+F4

comment:15 by shek, 2 years ago

This issue has increased in severity to the point that running VirtualBox on Linux hosts with Wayland has become very difficult.

comment:16 by Torsten Bronger, 2 years ago

I observe the following under Ubuntu 22.04 and Wayland: When I click on the VirtualBox menu at the rim of the VM window (e.g. “devices” or the icons to the right), the mouse pointer stays in the shape of the host and is unusable on host and guest on the window area of the VM (which usually is maximised). I have to switch off the VM to get normal behaviour back. Is this the same issue? If yes, it persists even in Ubuntu 22.04.

comment:17 by bluesceada, 6 months ago

I am waiting since a long time for this to get fixed, but it seems that it is not even worked on, or is it?

What is the progress here?

Is there any known workaround?

Thanks for any information!

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use