VirtualBox

Ticket #19044 (closed defect: fixed)

Opened 4 months ago

Last modified 3 months ago

VBoxDarwinAdditionsUninstall.tool in the GAs ISO is not set as executable => Fixed in SVN

Reported by: socratis Owned by:
Component: guest additions Version: VirtualBox 6.0.0
Keywords: VBoxDarwinAdditionsUninstall.tool Cc:
Guest type: OSX Server Host type: Mac OS X

Description

"VBoxDarwinAdditionsUninstall.tool" is not executable and cannot be run directly, has to be copied from the ISO somewhere locally, and "chmod +x" in order to work:

$ ls -l /Volumes/VBox_GAs_6.0.0/VBoxDarwinAdditionsUninstall.tool 
-r--r--r--  1 socratis  staff  3949 10 Δεκ  2018 /Volumes/VBox_GAs_6.0.0/VBoxDarwinAdditionsUninstall.tool

The issue actually exists since the beginning of time, when "VBoxDarwinAdditionsUninstall.tool" was first introduced with VirtualBox 6.0.0 RC1, and is still ongoing with 6.1.0b1+. Guess nobody noticed so far... ;)

Ref1:  http://download.virtualbox.org/virtualbox/6.0.0_RC1/VBoxGuestAdditions_6.0.0_RC1.iso

Ref2:  https://forums.virtualbox.org/viewtopic.php?f=22&t=90798&p=460950#p460948

Change History

comment:1 Changed 3 months ago by vushakov

  • Summary changed from VBoxDarwinAdditionsUninstall.tool in the GAs ISO is not set as executable to VBoxDarwinAdditionsUninstall.tool in the GAs ISO is not set as executable => Fixed in SVN

comment:2 Changed 3 months ago by socratis

  • Status changed from new to closed
  • Resolution set to fixed

Confirmed as fixed with:

  • 6.0.15 r134831 and later.
  • 6.1.0rc1 r134891 and later.

Thank you @vushakov...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use