VirtualBox

Ticket #19004 (closed defect: duplicate)

Opened 2 years ago

Last modified 18 months ago

Shared folders: rmdir on open directory fails with ETXTBSY

Reported by: anderskaseorg Owned by:
Component: shared folders Version: VirtualBox 6.0.12
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

In a shared folder mounted from a Windows 10 host (1903 build 18362.295) in an Ubuntu guest (I've tried 18.04 or 19.04) with Guest Additions 6.0.12 installed from the Guest Additions CD, the following unexpectedly fails:

root@osboxes:/mnt/test# mkdir foo
root@osboxes:/mnt/test# python3 -c 'import shutil; shutil.rmtree("foo")'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python3.7/shutil.py", line 495, in rmtree
    onerror(os.rmdir, path, sys.exec_info())
  File "/usr/lib/python3.7/shutil.py", line 493, in rmtree
    os.rmdir(path)
OSError: [Errno 26] Text file busy: 'foo'

strace reveals that Python has kept an open fd for the directory being removed.

Alternate reproduction recipe:

root@osboxes:/mnt/test# mkdir foo
root@osboxes:/mnt/test# perl -e 'opendir D, "foo"; rmdir "foo" or die $!'
Text file busy at -e line 1.

Attachments

ubuntu-test-2019-10-11-21-38-28.log Download (110.2 KB) - added by anderskaseorg 2 years ago.
VirtualBox log
ubuntu-test-2019-10-14-14-14-05.log Download (109.6 KB) - added by anderskaseorg 2 years ago.
VirtualBox log from test build

Change History

Changed 2 years ago by anderskaseorg

comment:1 Changed 2 years ago by paulson

Similar to ticket #19003, can you update the Guest Additions and then report back?

comment:2 Changed 2 years ago by anderskaseorg

Similar to ticket #19003, if you look at the log lines for the most recent boot, you’ll see that I did update the Guest Additions. The problem occurs with Guest Additions 6.0.12.

https://www.virtualbox.org/attachment/ticket/19004/ubuntu-test-2019-10-11-21-38-28.log#L1555

00:12:12.843089 VMMDev: Guest Additions information report: Version 6.0.12 r133076 '6.0.12'
Last edited 2 years ago by anderskaseorg (previous) (diff)

comment:3 Changed 2 years ago by paulson

OK, thanks for confirming that. Similar to #19003, I can't reproduce this on a Debian 10 guest or a Centos 7.7-1908 guest with the latest VirtualBox bits so could you try installing one of Testbuilds and the Guest Additions from there to see if this is still occurs for you?

comment:4 Changed 2 years ago by anderskaseorg

I can still reproduce with Guest Additions 6.0.13 r133740 on Ubuntu 19.04 on VirtualBox 6.0.13 r133800 on Windows 10 1903 build 18362.356.

Changed 2 years ago by anderskaseorg

VirtualBox log from test build

comment:5 Changed 2 years ago by anderskaseorg

For completeness, I can also reproduce with a Debian 10 guest or a CentOS 7.7-1908 guest.

comment:6 Changed 18 months ago by babydanks

I am running into this same issue with python "rmtree". It is causing headaches for our developers that use Windows 10 hosts with an Ubuntu 18.04 or 20.04 guest on VirtualBox version 6.0+. This renders the shared folder unusable for us, so we are contemplating a switch to docker or VMware. I hope this can get looked at soon! Thanks.

comment:7 Changed 18 months ago by fbatschu

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #19086

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use