VirtualBox

Ticket #18949 (closed defect: duplicate)

Opened 2 months ago

Last modified 2 months ago

5.2.32 Gues Modules Fail To Build on Linux 5.3

Reported by: drankinatty Owned by:
Component: guest additions Version: VirtualBox 5.2.32
Keywords: Cc:
Guest type: all Host type: Linux

Description

Attempting to update to Linux-5.3 on Archlinux causes failure to build modules:

gcc --version
gcc (GCC) 9.1.0

There are two primary areas of error:

  CC [M]  /var/lib/dkms/vboxhost/5.2.32/build/vboxpci/SUPR0IdcClient.o
/var/lib/dkms/vboxhost/5.2.32/build/vboxnetflt/linux/VBoxNetFlt-linux.c: In function ‘vboxNetFltLinuxEnumeratorCallback’:
/var/lib/dkms/vboxhost/5.2.32/build/vboxnetflt/linux/VBoxNetFlt-linux.c:2148:9: error: implicit declaration of function ‘for_ifa’ [-Werror=implicit-function-declaration]
 2148 |         for_ifa(in_dev) {
      |         ^~~~~~~
/var/lib/dkms/vboxhost/5.2.32/build/vboxnetflt/linux/VBoxNetFlt-linux.c:2148:24: error: expected ‘;’ before ‘{’ token
 2148 |         for_ifa(in_dev) {
      |                        ^~
      |                        ;
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:280: /var/lib/dkms/vboxhost/5.2.32/build/vboxnetflt/linux/VBoxNetFlt-linux.o] Error 1
make[1]: *** [scripts/Makefile.build:497: /var/lib/dkms/vboxhost/5.2.32/build/vboxnetflt] Error 2

  CC [M]  /var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/memobj-r0drv.o
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/SUPDrvTracer.o: warning: objtool: .text+0x7: indirect jump found in RETPOLINE build
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/SUPDrvTracer.o: warning: objtool: supdrvTracerProbeFireStub() is missing an ELF size annotation

and

  CC [M]  /var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/semeventmulti-r0drv-linux.o
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/mp-r0drv-linux.c: In function ‘VBoxHost_RTMpOnAll’:
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/mp-r0drv-linux.c:287:18: error: void value not ignored as it ought to be
  287 |         int rc = smp_call_function(rtmpLinuxAllWrapper, &Args, 0 /* wait */);
      |                  ^~~~~~~~~~~~~~~~~
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/mp-r0drv-linux.c: In function ‘VBoxHost_RTMpOnOthers’:
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/mp-r0drv-linux.c:341:8: error: void value not ignored as it ought to be
  341 |     rc = smp_call_function(rtmpLinuxWrapper, &Args, 1 /* wait */);
      |        ^
make[2]: *** [scripts/Makefile.build:281: /var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/mp-r0drv-linux.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/lib/dkms/vboxhost/5.2.32/build/vboxdrv/r0drv/linux/memuserkernel-r0drv-linux.o: warning: objtool: rtR0MemKernelCopyLnxWorker()+0x15: redundant CLD
make[1]: *** [scripts/Makefile.build:497: /var/lib/dkms/vboxhost/5.2.32/build/vboxdrv] Error 2
make: *** [Makefile:1624: _module_/var/lib/dkms/vboxhost/5.2.32/build] Error 2
make: Leaving directory '/usr/lib/modules/5.3.0-arch1-1-ARCH/build'

full make.log attached.

Attachments

make.log Download (5.5 KB) - added by drankinatty 2 months ago.
Full make.log file

Change History

Changed 2 months ago by drankinatty

Full make.log file

comment:1 Changed 2 months ago by fbatschu

this is a duplicate of already fixed bug:

#18911 Fixes for Linux kernel 5.3 wanted - part 1 https://www.virtualbox.org/ticket/18911

comment:2 Changed 2 months ago by fbatschu

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use