VirtualBox

Ticket #18916 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

VRDP enabled, clicking repeatedly on the sound level freezes WinVM/VirtualBox Manager

Reported by: socratis Owned by:
Component: RDP Version: VirtualBox 6.0.4
Keywords: RDP, audio, system sounds, VM freezes, VirtualBox Manager freezes Cc:
Guest type: Windows Host type: all

Description

Steps to reproduce

  • Enable RDP server on a Win VM that uses either IntelHDA or AC97, something like a WinXP, Win7 or Win10.
  • Launch VM, login.
  • On the sound icon in the System Tray, start clicking repeatedly on the sound level, same sound level.
  • VM freezes, VirtualBox Manager freezes, VM has to be killed by system-means.

Note that other sounds do not cause this, I had videos playing just fine.

Related discussion and a whole lot more information in the forums:  https://forums.virtualbox.org/viewtopic.php?f=6&t=91478

Attachments

VBox.log Download (95.3 KB) - added by socratis 2 years ago.
And the required VBox.log, from a 6.0.4 session, WinXP guest

Change History

Changed 2 years ago by socratis

And the required VBox.log, from a 6.0.4 session, WinXP guest

comment:1 Changed 2 years ago by socratis

BTW, in case it's not obvious by its absence in the "Steps to reproduce" procedure, you do not have to be remotely logged in. Just for the RDP server to be enabled.

comment:2 Changed 2 years ago by socratis

Summary of my findings (hosts, guests, versions):  https://forums.virtualbox.org/viewtopic.php?f=6&t=91478&start=15#p457222

comment:3 in reply to: ↑ description Changed 2 years ago by msys

Note that other sounds do not cause this, I had videos playing just fine.

It seems that the kind of sound is not important. Instead, it is about the quantity of sounds firing up in short succession. Some applications are triggering this bug while clicking through their options, probably because there is some sound associated with a click.

comment:4 Changed 22 months ago by socratis

  • Status changed from new to closed
  • Resolution set to fixed

This seems to have been fixed with 6.1.0. Verified by at least two users, see the  thread in the forums for more details...

Closing as [Fixed].

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use