VirtualBox

Ticket #18745 (closed defect: fixed)

Opened 4 months ago

Last modified 3 months ago

Vbox 6.0.8 keeps keyboard grab even after mouse is out -> fixed in openSUSE

Reported by: luizluca Owned by:
Component: GUI Version: VirtualBox 6.0.8
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

Hello,

I use OpenSUSE Tumbleweed with frequent updates (Linux kernel 5.1.15-1-default). Since last two releases, vbox mouse integration is not working as expected.

When I have mouse integration enabled, I expected that VM looses keyboard grab as soon as mouse cursor is out. However, vbox captures it back.

Steps to reproduce:

  1. Start a VM (tested with win7 or win10). Additions are installed but it happens even during boot.
  2. Opened an editor in my host machine (OpenSUSE Tumbleweed)
  3. Put VM and editor window side by side
  4. Click inside the VM to let it grab keyboard
  5. Click inside the editor to leave VM. At this point, I can type one or two characters before vbox grab keyboard back.

The only way to make vbox leave keyboard alone is using "host key" (in my case, left super (win)).

I'm using vbox RDP as a workaround while this is happening.

Machine is also eventually crashing, freezing VM window without any entry in Vbox.log.

Change History

comment:1 in reply to: ↑ description Changed 4 months ago by socratis

Replying to luizluca:

When I have mouse integration enabled, I expected that VM looses keyboard grab as soon as mouse cursor is out.

When the mouse is out of the VM area? Or when the VM loses the focus?

It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved in the forums, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of.

Please, open a new thread in the  VirtualBox on Linux Hosts section of the forums. Please be sure to mention that you came from the bug tracker and include the ticket number.

comment:2 Changed 3 months ago by michael

Which package are you using? One from virtualbox.org or from the openSUSE repositories?

comment:3 Changed 3 months ago by luizluca

I'm using packages from openSUSE repositories. I just opened a new thread:  https://forums.virtualbox.org/viewtopic.php?f=7&t=93849&p=452639#p452639

After that, I checked again package changes (build.opensuse.org) and I noticed that someone has already reported:

 https://bugzilla.suse.com/show_bug.cgi?id=1140084

It seems to be an issue with Qt 5.13. And there is a patch:

 https://build.opensuse.org/package/view_file/Virtualization/virtualbox/fixes_focus_steal.patch?rev=0e144aefccead1381ac0c131ffbdb55d

comment:4 Changed 3 months ago by michael

  • Summary changed from Vbox 6.0.8 keeps keyboard grab even after mouse is out to Vbox 6.0.8 keeps keyboard grab even after mouse is out -> fixed in openSUSE

Yes, I wrote the patch after SUSE's Fabian Vogt and Larry Finger tracked down the problem. Thanks for the update!

comment:5 Changed 3 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use