VirtualBox

Ticket #1872 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Random Crash => please retry with version 1.7 when it is released

Reported by: mndo Owned by:
Priority: major Component: GUI
Version: VirtualBox 1.6.2 Keywords:
Cc: ams@… Guest type: other
Host type: Linux

Description

I am running VirtualBox on Ubuntu 8.04.1 as host, when i run VirtualBox and choose a Guest it won't boot. From the logs I get:


00:00:38.619 Changing the VM state from 'DESTROYING' to 'TERMINATED'. 00:00:38.677 ERROR [COM]: aRC=NS_ERROR_UNEXPECTED (0x8000ffff) aIID={09789f63-4525-48e5-5e4-1080453b0eab} aComponent={Display} aText={The object is not ready} aWarning=false, preserve=false


If i run VirtualBox -startvm <vm>, i get:


kiosk@kiosk:~$ VirtualBox -startvm ttt2

Xlib: extension "XInputExtension" missing on display "127.0.0.1:1.0".

Qt WARNING: Failed to get list of devices Qt WARNING: X Error: BadWindow (invalid Window parameter) 3

Major opcode: 3 Minor opcode: 0 Resource id: 0x20001ad

Qt WARNING: X Error: BadValue (integer parameter out of range for operation) 2

Major opcode: 78 Minor opcode: 0 Resource id: 0xb751f130

Qt WARNING: X Error: BadDrawable (invalid Pixmap or Window parameter) 9

Major opcode: 55 Minor opcode: 0 Resource id: 0x20001ad

Qt WARNING: X Error: BadWindow (invalid Window parameter) 3

Major opcode: 2 Minor opcode: 0 Resource id: 0x20001ad

Qt WARNING: X Error: BadWindow (invalid Window parameter) 3

Major opcode: 2 Minor opcode: 0 Resource id: 0x20001ad

Segmentation fault kiosk@kiosk:~$


If i increase ulimit -c from zero (ubuntu's default) to unlimited it works most of the time.

A core dump can be found  here.

Change History

comment:1 Changed 6 years ago by michael

Backtrace:

(gdb) bt
#0  0x00000000 in ?? ()
#1  0xb758a1b5 in SDL_VideoModeOK () from /usr/lib/libSDL-1.2.so.0
#2  0xb758a304 in SDL_WM_SetIcon () from /usr/lib/libSDL-1.2.so.0
#3  0xb758a7b0 in SDL_GL_GetAttribute () from /usr/lib/libSDL-1.2.so.0
#4  0xb758ae06 in SDL_UpdateRect () from /usr/lib/libSDL-1.2.so.0
#5  0x081c92b2 in VBoxSDLFrameBuffer::resizeEvent ()
#6  0x0819c8e6 in VBoxConsoleView::VBoxConsoleView ()
#7  0x081b1ef3 in VBoxConsoleWnd::openView ()
#8  0x0815e9bc in VBoxGlobal::startMachine ()
#9  0x08140c26 in main ()

Note also:

GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...

warning: Can't read pathname for load map: Input/output error.

warning: .dynamic section for "/usr/lib/libSDL-1.2.so.0" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

comment:2 follow-up: ↓ 3 Changed 6 years ago by michael

mndo: can you try starting VirtualBox as

$ VirtualBox -startvm ttt2 -rmode image

and see if the crash is still reproducible?

comment:3 in reply to: ↑ 2 Changed 6 years ago by mndo

Replying to michael:

mndo: can you try starting VirtualBox as

$ VirtualBox -startvm ttt2 -rmode image

and see if the crash is still reproducible?

Yes, it is..

Core dump  here.

comment:4 Changed 6 years ago by michael

New URL for the core dump in comment 3:  http://intra.eufinity.com/ams/VBox/core.16336.bz2

comment:5 Changed 6 years ago by michael

The backtrace is identical.

comment:6 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Random Crash to Random Crash => please retry with version 1.7 when it is released

I checked in the source and "-rmode image" is not actually enabled for VirtualBox 1.6. For version 1.7 SDL mode is not defined, so I assume that this issue will go away in 1.7, which should arrive pretty soon.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use