VirtualBox

Ticket #18667 (closed defect: fixed)

Opened 6 months ago

Last modified 4 months ago

Kernel panic in Debian 9 guest at shut down when shared folders are enabled => Fixed in SVN

Reported by: danham Owned by: bird
Component: other Version: VirtualBox 6.0.6
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

When shared folders are enabled the guest experiences a kernel panic at shutdown. When shared folders are disabled the guest shuts down as expected.

This issue seems to affect Debian guests only (CentOS seems to be fine).

I have attached two sets of files showing the VBox.log, the guest console output (minicom.cap), and where applicable, a core dump captured with VBoxManage debugvm.

The files with the "error_" prefix were captured with shared folders enabled - the error_minicom.cap file shows the output from the kernel panic. The core dump was taken immediately after the panic had occurred.

The files marked with the "normal_" prefix were captured with shared folders disabled (no panic) and should hopefully provide a useful baseline.

Attachments

error_VBox.log Download (117.0 KB) - added by danham 6 months ago.
VBox log with shared folders enabled (guest panics)
error_minicom.cap Download (28.3 KB) - added by danham 6 months ago.
Guest console output with shared folders enabled (kernel panics)
normal_VBox.log Download (116.6 KB) - added by danham 6 months ago.
VBox log with shared folders disabled (no guest panic)
normal_minicom.cap Download (22.4 KB) - added by danham 6 months ago.
Guest console output with shared folders enabled (no guest panic)

Change History

Changed 6 months ago by danham

VBox log with shared folders enabled (guest panics)

Changed 6 months ago by danham

Guest console output with shared folders enabled (kernel panics)

Changed 6 months ago by danham

VBox log with shared folders disabled (no guest panic)

Changed 6 months ago by danham

Guest console output with shared folders enabled (no guest panic)

comment:1 Changed 6 months ago by danham

I was not able to attach the core dump as the file is too large (1.1GB). Is there another mechanism for uploading the file?

comment:2 Changed 6 months ago by Dariusz

I have the same issue. I provided logs and details on the forum:

 https://forums.virtualbox.org/viewtopic.php?f=8&t=92801

In short since VirtualBox 6.0.6 (including latest build 6.0.9-130662) as soon as extensions are upgraded above 6.0.4 Debian clients crash during shutdown/reboot if shared folders are used. With 6.0.6 and 6.08 it was kernel panic, with 6.0.9 it just hangs with black screen.

All works if I stick to 6.0.4 extensions.

Clearly something was broken moving to 6.0.6

I use Debian extensively and happy to help with any testing required to make it fixed.

comment:3 Changed 6 months ago by jeansen

Same here. Up until 6.0.4 all worked fine, but since then whenever I shut-down my VM, I get the kernel message. I've installed a fresh Debian stable system, added the guest tools 6.0.8 and even it is no difference.

In the logs I cannot see anything. Except that the last line is always:

00:00:32.491665 VMMDev: vmmDevHeartbeatFlatlinedTimer: Guest seems to be unresponsive. Last heartbeat received 4 seconds ago

Host: Debian 10 (buster) Linux debian-omph 4.19.0-5-amd64 #1 SMP Debian 4.19.37-3 (2019-05-15) x86_64 GNU/Linux

Guest: Debian 9 (stretch) Linux test-mbr 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 GNU/Linux

It also seems that this issue is only present when there are shared folders configured ...

Last edited 6 months ago by jeansen (previous) (diff)

comment:4 Changed 6 months ago by bird

  • Owner set to bird
  • Status changed from new to assigned

I've reproduced the issue.

Just a tip how to get the current dmesg from a guest (debian909 in this example) using the VBox guest debugging feature via VBoxManage:

VBoxManage debugvm debian909 osdetect
VBoxManage debugvm debian909 osdmesg

comment:5 Changed 6 months ago by bird

  • Summary changed from Kernel panic in Debian 9 guest at shut down when shared folders are enabled to Kernel panic in Debian 9 guest at shut down when shared folders are enabled => Fixed in SVN

Found the issue. Incorrect version range check around a bdi_destroy() call, causing BDI structure to linger after cleanup. Also responsible for EEXIST errors reloading vboxsf.ko and remounting shares. Fixed in r78890 (internal revision 131008).

comment:6 Changed 6 months ago by Dariusz

Good news! As soon as available in test builds I will test it.

Last edited 6 months ago by Dariusz (previous) (diff)

comment:7 Changed 6 months ago by danham

Great work! Can we expect to see this in the next release?

comment:8 follow-up: ↓ 9 Changed 6 months ago by CReibenstein

The problem still occurs in 6.0.8, so I am not sure if it has really been fixed.

As a work-around, you can install the guest extensions from version 6.0.4. Then everything works fine.

comment:9 in reply to: ↑ 8 Changed 6 months ago by socratis

Replying to CReibenstein:

The problem still occurs in 6.0.8, so I am not sure if it has really been fixed.

CReibenstein
As 'bird' (a developer) said, this was fixed in r131008, 6.0.8 was r130520. So, why do you expect 6.0.8 to have the fix? It doesn't! The fix was implemented 512 revisions after 6.0.8 was released...

Either you have to wait for 6.0.10, or try the Testbuilds with a revision>131008.

comment:10 Changed 5 months ago by Dariusz

I have just tested latest Testbuild 6.0.9 r131254 - all works OK now with Debian guests and macOS host

comment:11 Changed 4 months ago by michael

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use