VirtualBox

Ticket #18593 (closed defect: fixed)

Opened 4 months ago

Last modified 5 weeks ago

USB Printer not work (ver. 5.2.28 or 6.0.6): fixed in svn

Reported by: Okey Owned by:
Component: USB Version: VirtualBox 5.2.28
Keywords: printer , canon Cc:
Guest type: Windows Host type: Windows

Description

Hi, I've using VirtualBox on Windows10-64bit host for years, to run USB printer CANON LBP-1210 with guest:Windows7-32bit. My aim is to use an old USB printer with the latest Windows. Every time, I give instructions to start using the USB port (right-cntl/device/usb...).

Everything worked fine until Version 5.2.26

After upgrading to 5.2.28, error occurs and freeze (VBox stop). And VirtualBox 6.0.6 occurs error same. Coming back to 5.2.26 make it work fine again. New versions have problems with USB ?

best regard.

Attachments

VBox.log.2 Download (148.9 KB) - added by TKL 4 months ago.
Logfile containing OHCI#0: Raising unrecoverable error messages
VBox.log Download (147.9 KB) - added by TKL 3 months ago.
Testbuild logfile
VBox.2.log Download (148.1 KB) - added by TKL 3 months ago.
Logfile for development revision 130571
VBox.3.log Download (148.8 KB) - added by TKL 3 months ago.
logfile for development revision 130576
VBox.4.log Download (149.7 KB) - added by TKL 3 months ago.
logfile for development revision 130601

Change History

comment:1 Changed 4 months ago by TKL

Hi, this problem seems to affect all sorts of USB devices. We can reproduce it with several PCs and with both current versions of VirtualBox 5.2 and 6.0.

Downgrading to the release from January, 28 fixes the issue for both release branches.

Changed 4 months ago by TKL

Logfile containing OHCI#0: Raising unrecoverable error messages

comment:2 Changed 3 months ago by TKL

Oh, yes. We are using Debian 9 with Kernels amd64 4.9 and 4.19 (stretch-backports).

comment:3 Changed 3 months ago by TKL

And current version of Windows 10 (64bit) as Guest.

Last edited 3 months ago by TKL (previous) (diff)

comment:4 Changed 3 months ago by aeichner

What kind of devices are you encountering the issue with?

comment:5 Changed 3 months ago by TKL

So far, we had this issues with an Dymo Label Printer ("Label Manager PnP"), our Spectrometers (FTDI FT245BL-based) and a JTAG interface (XDS510USB).

An FTDI USB-Serial converter (FT232-based) worked without problems (using a low data rate).

We are not using the extension pack. So all devices are accessed via USB 1.1.

comment:6 Changed 3 months ago by dwl100tr

Same problem here with Brother label printers - QL-560 and QL-700. Neither work with 5.2.28 but all my other USB printers do. Both label printers work after downgrade to 5.2.26

comment:7 Changed 3 months ago by michaln

If you go to https://www.virtualbox.org/wiki/Testbuilds and grab a development snapshot (not 5.2.x or 6.0.x build) revision 130571 or later, it should provide additional information with the "Raising unrecoverable error" messages in VBox.log. If you then provide the new VBox.log, we can try to fix something.

Changed 3 months ago by TKL

Testbuild logfile

comment:8 Changed 3 months ago by TKL

Please find attached a logfile of the Testbuild, showing the issue. I just started the VM, connected one of our Spectrometers (FTDI FT245BL/libusb-based) and shut it down.

comment:9 Changed 3 months ago by TKL

I just realized: I used the wrong version (6.0.x build). Sorry. I will deliver the correct log in a couple of minutes.

Changed 3 months ago by TKL

Logfile for development revision 130571

comment:10 Changed 3 months ago by michaln

Thanks, that is helpful. Please try again with development build revision 130575 or later. That should provide further information.

Changed 3 months ago by TKL

logfile for development revision 130576

comment:11 Changed 3 months ago by michaln

Thanks. Now could you please try development build revision 130596 or later? That should have a fix, but it needs testing.

comment:12 Changed 3 months ago by TKL

Great job! Everything seems to be working again. We still have a problem with the formerly mentioned JTAG interface, but this may be another issue. (Now it does not work with the January version anymore...)

We successfully connected spectrometers and the Dymo Label Printer (which are not working with current release).

However the test release seems to be running slower than the last working release. Maybe because of activated debugging options?

I will also attach a log. However it does not seem to contain any errors.

Changed 3 months ago by TKL

logfile for development revision 130601

comment:13 Changed 3 months ago by michaln

Can you define "running slower"? There is no debugging code, really.

comment:14 Changed 3 months ago by socratis

comment:15 Changed 3 months ago by TKL

False alarm. Speed of the VM seems normal.

comment:16 Changed 3 months ago by michaln

  • Summary changed from USB Printer not work (ver. 5.2.28 or 6.0.6) to USB Printer not work (ver. 5.2.28 or 6.0.6): fixed in svn

5.2.x and 6.0.x test builds with the OHCI fix are now available.

If there are remaining issues, please report details, otherwise this will just stay marked as fixed for the next maintenance release.

comment:17 Changed 3 months ago by TKL

It's okay for me. Thank you very much!

comment:18 Changed 3 months ago by Okey

My printer LBP-1210(USB1.0) is working with test builds.

VirtualBox-5.2.31-130663-Win VirtualBox-6.0.9-130662-Win (both , with Extension_Pack and GuestAdditions)

host OS:Win10pro (64bit) guest OS:Win7pro (32bit)

VBox Setting USB1.1(OHCI) or USB2.0(EHCI), both are good. My PC is not equipped with USB3.

Thank you.

comment:19 Changed 3 months ago by michaln

Thanks for reporting.

For the sake completeness: Your host does not need to have USB 3.0 support for VirtualBox to emulate the xHCI (aka "USB 3.0") controller. The xHCI controller handles USB traffic of all speeds, if you have no USB 3.0 on the host it just means the emulated controller will never see SuperSpeed (USB 3.0) devices, but it will handle USB 1.x and 2.0 devices just fine.

comment:20 Changed 5 weeks ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use