VirtualBox

Ticket #18518 (closed defect: fixed)

Opened 8 weeks ago

Last modified 5 weeks ago

RDPing to a VM with VMSVGA sends only 1 frame, then screen updates stop -> fixed after 6.0.4

Reported by: socratis Owned by:
Component: RDP Version: VirtualBox 6.0.0
Keywords: VMSVGA, frozen RDP Cc:
Guest type: all Host type: all

Description

  • Create/Select any VM that has the Graphics Controller set to VMSVGA.
  • Enable the RDP server.
  • Start the VM and connect via an RDP client, MSRDP for OSX or Remmnina will do.
  • Connection is successful, but after the first frame comes in, no updates occur.
  • Mouse/keyboard input continue to work, so the connection itself is fine.
  • The 3D acceleration setting is irrelevant.
  • The same exact setup, but with the Graphics Controller set to VBoxVGA works as expected.
  • Behavior started with 6.0.0.
  • Log files for VBoxVGA/VMSVGA are identical as two drops of water.

Related discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=3&t=92313

Change History

comment:1 Changed 8 weeks ago by socratis

I just realized that the title of the ticket is wrong. Instead of "VRDPing to a VM..." can someone rename that to simply "RDPing to a VM..."? That "V" is superfluous there. TIA.

comment:2 Changed 8 weeks ago by gombara

  • Summary changed from VRDPing to a VM with VMSVGA sends only 1 frame, then screen updates stop to RDPing to a VM with VMSVGA sends only 1 frame, then screen updates stop

comment:3 Changed 5 weeks ago by michael

  • Summary changed from RDPing to a VM with VMSVGA sends only 1 frame, then screen updates stop to RDPing to a VM with VMSVGA sends only 1 frame, then screen updates stop -> fixed after 6.0.4

comment:4 Changed 5 weeks ago by socratis

Seems to be fixed with 6.0.5 r129665 or later...

\o/

comment:5 Changed 5 weeks ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use