VirtualBox

Ticket #1844 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

files in shared folder with 30.3

Reported by: wk Owned by:
Priority: trivial Component: shared folders
Version: VirtualBox 1.6.2 Keywords: files with 30.3
Cc: Guest type: Windows
Host type: Windows

Description

Sorry, my english isn't very well - so werde ich es ausführlich in Deutsch beschreiben...

Short englisch description: In shared folders is a problem with files like 30.3 (30 characters for the name, a "dot" and three characters for the extension). All files to and inclusive the first file with 30.3 are not displayed. After the first file with 30.3 all files are displayed - also the following files with 30.3.

WinXP-SP3 on WinXP-SP3

Grundsätzlich funktioniert die 1.6.2 auch mit den Shared Folder (Gemeinsame Ordner - also " net use x: \vboxsvr\Freigabe" oder über den Explorer "Netzwerkumgebung-Gesamtes Netzwerk-VirtualBox Shared Folders-\VBOXSVR\Freigabe".

Ich habe ein Verzeichnis mit 23 Einträgen, sehe aber nur die letzten drei. Ich habe auch feststellen können warum: Die viertletzte Datei ist Schuld! Sie heißt: "Niemand Hört Dich - Nevada Tan.mp3" ...und hat genau 34 Zeichen (30 Zeichen für den Namen, "Punkt" und 3 Zeichen für die Endung - also 30.3). Sowie ich irgendein Zeichen hinzufüge oder wegnehme werden alle Inhalte aus dem Verzeichnis angezeigt!

Natürlich habe ich weiter experimentiert: Alle Dateien bis zur und inklusive der ersten Datei mit 34 Zeichen (30.3) werden in einem Shared Folder nicht angezeigt. Alle auf die erste Datei mit 34 Zeichen folgenden Dateien werden angezeigt. Auch die mit 34 Zeichen...

Falls es wichtig ist: XP-SP3 auf XP-SP3

Change History

comment:1 Changed 6 years ago by pentagonik

I'll take a look at it. Thanks for the report.

comment:2 Changed 6 years ago by wk

please look here:  http://forums.virtualbox.org/viewtopic.php?p=28926#28926

There is a longer text in German...

comment:3 follow-up: ↓ 4 Changed 6 years ago by frank

VirtualBox 1.6.4 contains a fix for such a problem. Please could you check if upgrading solves the problem for you? Please make sure to upgrade the guest additions as well.

comment:4 in reply to: ↑ 3 Changed 6 years ago by wk

Thanks Frank! The problem is fixed. It is nessasary to install the new guest additions. Without the new guest additions the problem alredy exists.

comment:5 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use