VirtualBox

Ticket #18408 (closed defect: fixed)

Opened 8 months ago

Last modified 5 months ago

Exiting seamless mode does not revert guest display back to previous resolution -> fixed after (not in) 6.0.4 and in test builds

Reported by: thoms Owned by:
Component: GUI/seamless Version: VirtualBox 6.0.4
Keywords: revert display resolution centos6 Cc:
Guest type: Windows Host type: Linux

Description

In prior VBox versions (< 6.0), the behaviour when exiting from seamless mode was to revert the guest screen resolution back to its previous settings immediately before entering seamless mode. In 6.0.4 (and possibly 6.0.0 and 6.0.2 -- did not test), when exiting from seamless mode the guest screen resolution is set to full-screen, effectively forgetting the prior resolution settings.

Change History

comment:1 Changed 8 months ago by socratis

I was about to file a bug report myself, but you were here first ;)

I did some testing today, and it's not seamless only, but full screen as well. Actually that's how the whole discussion started:  Exit Full Screen doesn't revert to resolution prior.

The reason, as seen in the discussion, is that the 'ExtraDataItem name="GUI/LastGuestSizeHint"' value changes when in full/seamless to something that it shouldn't.

Tested with 6.0.4, it fails. Tested with 5.2.26, it works. Methinks it's a 6.0.0 regression.

Last edited 8 months ago by socratis (previous) (diff)

comment:2 Changed 8 months ago by michael

Could you please give the current development (not 6.0!) test builds a try?

wiki:Testbuilds

comment:3 Changed 7 months ago by michael

  • Summary changed from Exiting seamless mode does not revert guest display back to previous resolution to Exiting seamless mode does not revert guest display back to previous resolution -> fixed after (not in) 6.0.4 and in test builds

The 6.0 test builds now contain the fix too.

comment:4 Changed 7 months ago by isgdre

Just an FYI. "Methinks it's a 6.0.0 regression." I've been using VirtualBox since VirtualBox-4.0.8-71778 and I don't remember it ever doing this.

comment:5 Changed 5 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use