VirtualBox

Ticket #1838 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

iPhone/iTouch on VirtualBox 1.6.2 fails (error code 0xE8000035)

Reported by: Snyke Owned by:
Priority: major Component: USB
Version: VirtualBox 1.6.4 Keywords: iphone, ipod, itouch, usd, windows
Cc: Guest type: Windows
Host type: Linux

Description

My iPhone 3G won't connect to iTunes in Windows (on a Fedora 9 host) complaining with an error code 0xE8000035

Other USB devices connect perfectly (and even a 2nd generation nano works perfectly with iTunes) but the iPhone 3G doesn't.

Change History

comment:1 follow-up: ↓ 21 Changed 6 years ago by Snyke

Same goes for openSuSe 10.2 with the same setup and an iPod Touch (FW 1.1.3).

comment:2 Changed 6 years ago by niiiick

Same issue, same error code; Ubuntu 8.04, iTunes 7.7, original iPhone (non-3g) with 2.0 firmware.

comment:3 Changed 6 years ago by cdukes

Same problem here as "niiiick", except I have the new iPhone 3G

comment:4 follow-up: ↓ 5 Changed 6 years ago by kupesoft

Same error on the iPhone 3G.

comment:5 in reply to: ↑ 4 Changed 6 years ago by kupesoft

Replying to kupesoft:

Same error on the iPhone 3G.

Like cdukes, I'm on Ubuntu 8.04, iTunes 7.7, and the iPhone 3G.

comment:6 Changed 6 years ago by RayRayAngel

Same. Ubuntu 8.04, iTunes 7.7, Edge iPhone running 2.0 firmware.

comment:7 follow-ups: ↓ 8 ↓ 9 Changed 6 years ago by smaroudas

same for me! ipod touch, winxp, itunes 7.7. In vmware it works normally. What should i do?

comment:8 in reply to: ↑ 7 Changed 6 years ago by kupesoft

Replying to smaroudas:

same for me! ipod touch, winxp, itunes 7.7. In vmware it works normally. What should i do?


I guess use VMWare for the time being?

USED TO GET THE ATTENTION OF THE DEVS TO FIX THIS BUG ;p

comment:9 in reply to: ↑ 7 ; follow-up: ↓ 10 Changed 6 years ago by RayRayAngel

Replying to smaroudas:

same for me! ipod touch, winxp, itunes 7.7. In vmware it works normally. What should i do?

Well now that I know it works in Vmware I'm going to just splurge and buy it. Yes... this single feature is that important to me.

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 11 Changed 6 years ago by kupesoft

Replying to RayRayAngel:

Replying to smaroudas:

same for me! ipod touch, winxp, itunes 7.7. In vmware it works normally. What should i do?

Well now that I know it works in Vmware I'm going to just splurge and buy it. Yes... this single feature is that important to me.

Sadly, it's a killer feature that is also a seller for me. Anyone tried [K]Qemu?

comment:11 in reply to: ↑ 10 Changed 6 years ago by RayRayAngel

Replying to kupesoft:

Replying to RayRayAngel:

Replying to smaroudas:

same for me! ipod touch, winxp, itunes 7.7. In vmware it works normally. What should i do?

Well now that I know it works in Vmware I'm going to just splurge and buy it. Yes... this single feature is that important to me.

Sadly, it's a killer feature that is also a seller for me. Anyone tried [K]Qemu?

I haven't tried it yet but I did get the VMware client and my iPhone is working GREAT in it. I had heard rumors that it wasn't working but I got everything up and running in no time and now I can finally have me some iPhone sync goodness without having to reboot.

I would say that I'd be back to VirtualBox but seeing as how I just shelled out real life cash for VMware I'd be hard pressed to come back.

comment:12 follow-up: ↓ 13 Changed 6 years ago by adrien

Confirmed NOT working

Iphone 3G 8GB Virtual box 1.6.2 Windows XP Itunes 7

comment:13 in reply to: ↑ 12 ; follow-up: ↓ 14 Changed 6 years ago by mef

Replying to adrien:

Confirmed NOT working

Iphone 3G 8GB Virtual box 1.6.2 Windows XP Itunes 7

Confirmed for me, iphone 3g 8gb, itunes 7.7.4.3 on windows xp sp2 on virtualbox 1.6.2 host os ubuntu hardy

comment:14 in reply to: ↑ 13 Changed 6 years ago by mef

Replying to mef:

Replying to adrien:

Confirmed NOT working

Iphone 3G 8GB Virtual box 1.6.2 Windows XP Itunes 7

Confirmed for me, iphone 3g 8gb, itunes 7.7.4.3 on windows xp sp2 on virtualbox 1.6.2 host os ubuntu hardy

Confirmed as not working, that is.

comment:15 Changed 6 years ago by mef

This may be the same issue as #1413

comment:16 Changed 6 years ago by bkummel

I've exactly the same problem: Running Windows XP as guest on an Ubuntu 8.04 host. iTunes, 7.7 and a brand new iPhone 3G.

comment:17 follow-up: ↓ 19 Changed 6 years ago by mef

Anyone who wants a temporary fix, the trial version of VMware Workstation 6.04 works for me. Running XP, hosted on ubuntu, iphone3g + itunes 7.7. Trial lasts for 30 days, so I dunno what I'm gonna do if virtualbox isn't fixed by then... maybe shell out :(

comment:18 Changed 6 years ago by kupesoft

Confirmed not working on VirtualBox 1.6.4, Ubuntu 8.04 x86 host, Windows XP guest with the iPhone 3G and iTunes 7.7 and 7.7.1.

A cookie for the dev who gets on this one! We're just dying for this fix...

comment:19 in reply to: ↑ 17 Changed 6 years ago by scottywz

Replying to mef:

Anyone who wants a temporary fix, the trial version of VMware Workstation 6.04 works for me. Running XP, hosted on ubuntu, iphone3g + itunes 7.7. Trial lasts for 30 days, so I dunno what I'm gonna do if virtualbox isn't fixed by then... maybe shell out :(

VMWare Player works as well, and it's free! That's what I'm using right now until this bug is fixed (if it will ever be fixed).

comment:20 Changed 6 years ago by kprav33n

I confirm this issue on VirtualBox 1.6.4, host: Debian GNU/Linux; guest: Microsoft Windows XP Professional; iTunes 7.7; iPhone 3G.

Is there any developer comment on this ticket so far? Any extra information is needed like a log file or core file? I can help in fixing this issue.

comment:21 in reply to: ↑ 1 Changed 6 years ago by newman

Replying to Snyke:

I have an iPod 3g with freshly upgraded 2.0.1 software and upgraded iTunes 7.7.1 software running under a patched version of 32-bit Windows XP under VirtualBox 1.6.2 on a Dell 630 (Dual core 64-bit) running Ubuntu 8.0.4.

Problem persists and I understand it hasn't been addressed by the VirtualBox 1.6.4 upgrade. The VirtualBox developers seem mute on this point thus far and I know it is important to many of us to get this working!!!

I AM WILLING TO CONTRIBUTE MY EXPERTISE AS A SOFTWARE DEVELOPER TO HELP ADDRESS THIS. The USB code is not part of the OSE distribution as far as I can tell and I will need access to it in order to make progress.

Filling out the SCA doesn't appear sufficient to gain access to the USB code base. I am willing to sign an NDA with Sun if necessary.

Anyone? I can't promise I'll fix it but I promise I'll take a shot at it. This appears more (thus far) than the "offical" developers have promised.

Takers?

/Andy

comment:22 Changed 6 years ago by kupesoft

Some dev response please! This is killing us...

comment:23 Changed 6 years ago by jugglefish

seeking for solution as well. Don't like returning to vmware that much ... :-<

comment:24 Changed 6 years ago by kprav33n

Can the devs confirm if the root cause is known? If you need more information or planning not to fix, someone should update this ticket.

comment:25 follow-up: ↓ 26 Changed 6 years ago by sandervl73

  • Version changed from VirtualBox 1.6.2 to VirtualBox 1.6.4

Indeed looks like a duplicate of 1413, so it's a known problem. The next VBox version will not contain a fix, but it's on our todo list (which is rather large). Fortunately we have iPhones here (although no 3G models yet).

comment:26 in reply to: ↑ 25 Changed 6 years ago by kupesoft

Replying to sandervl73:

Indeed looks like a duplicate of 1413, so it's a known problem. The next VBox version will not contain a fix, but it's on our todo list (which is rather large). Fortunately we have iPhones here (although no 3G models yet).

All right, thanks for the response! Bummer that it won't be included in 1.6.4+1, but we're holding tight.

comment:27 Changed 6 years ago by venture

I have same problem with my iphone 2g. ubuntu 8.04+virtualbox 1.6.4+itunes 7.7.1+iphone 2.01 firmware

comment:28 Changed 6 years ago by kupesoft

On VMWare Workstation 6.0.4 until fixed. Confirmed working.

comment:29 Changed 6 years ago by alvarezp

@developers: what can the community do to help fix this issue?

comment:30 follow-up: ↓ 40 Changed 6 years ago by sandervl73

Unfortunately you will have to be a bit more patient. Our USB developer will be busy for the next few weeks. Only afterwards can he return to USB related work. I'll ask him to look at the iPhone problems.

comment:31 in reply to: ↑ description Changed 6 years ago by jvboyle

I have confirmed that version 2.0 also dose not have the Fix. Hopefully Vmware will not be the only VM software that can get this working . Maybe we can ask there Developers how it was fixed ?

comment:32 Changed 6 years ago by sandervl73

When we think we've fixed the problem we'll mention it here. 2.0 did not contain any USB fixes related to this defect.

comment:33 Changed 6 years ago by ericblue

I am not a VirtualBox user yet, however I plan to get it installed on my wife's laptop shortly. I recently tried to get my iPhone 3G working with my VMWare instance of XP SP2 and encountered the *exact* same error. As others have mentioned, VMWare addressed this in Workstation version 6.0.3. I'm not sure what the technical specifics are, but from there release notes:

"With Workstation 6.0.2 the iPhone might be seen as a camera device by a Windows guest but iTunes did not list the device in its device list. In Workstation 6.0.3, the iPhone is usable and visible in iTunes for Windows guests.”

I was running 6.0.2, so it took me a while to finally uncover this.

 http://eric-blue.com/2008/09/07/how-to-sync-your-iphone-3g-linux/

I'm hoping that VirtualBox will get this resolved as well, since I'm anxious to get this setup and installed on a few other machines.

comment:34 Changed 6 years ago by Apple_Eater

I can also confirm this issue with XP Pro SP3 running under Ubuntu 8.04 with VirtualBox 2.0

comment:35 Changed 6 years ago by kupesoft

Confirmed broken on iTunes 8 through Ubuntu 8.04 with Windows XP guest.

comment:36 Changed 6 years ago by shazow

Confirmed this issue on: Gentoo, VirtualBox 2.0, iTunes 8

Eagerly awaiting a fix.

comment:37 Changed 6 years ago by dgtlrift

Confirmed this issue on: Hardy Ubuntu 8.0.4 - 2.6.24-19-generic, VirtualBox 1.6.6, iTunes 8

comment:38 Changed 6 years ago by kupesoft

Confirmed with VirtualBox 2.0.2 and iTunes 8, on Ubuntu 8.04 host and Windows XP Pro guest.

Eagerly awaiting a fix as well.

comment:39 Changed 6 years ago by xente

Confirmed as well with VirtualBox 2.0.2 and iTunes 8 on Debian lenny host and winxp pro guest. Hope it gets fixed really soon.

comment:40 in reply to: ↑ 30 Changed 6 years ago by dgtlrift

Replying to sandervl73:

Unfortunately you will have to be a bit more patient. Our USB developer will be busy for the next few weeks. Only afterwards can he return to USB related work. I'll ask him to look at the iPhone problems.

Has there been any progress at resolving this issue, or has there been any engineer assigned to this issue yet? It's been over 3 weeks now since your post to appease the masses, but I think the natives are growing restless - especially since there are new iPhone updates which are unreachable via VirtualBox. What is the typical turn around time to fix an issue?

comment:41 Changed 6 years ago by sandervl73

If there is progress, it will be posted here. Typical turn around time to fix an issue? That entirely depends on the issue.

comment:42 Changed 6 years ago by eighthsin

some progress is being made under another ticket:

 http://www.virtualbox.org/ticket/491

comment:43 Changed 6 years ago by sandervl73

Let's continue this in #491. There's a (partial) workaround there.

comment:44 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use