VirtualBox

Ticket #18341 (closed defect: fixed)

Opened 10 months ago

Last modified 7 months ago

VBoxManage showvminfo segfault in 6.0.x -> fixed in releases after 6.0.4

Reported by: gizero Owned by: pentagonik
Component: other Version: VirtualBox 6.0.2
Keywords: USB passthrough Cc:
Guest type: Linux Host type: Linux

Description

After upgrading to 6.0, already existing VMs that used USB passthrough (at least one filter enabled) stopped being controllable by vagrant. After quick inspection I noticed this is not an issue with vagrant itself, but a consequence of it running VBoxManage showvminfo behind the scenes for its own purposes.

Indeed the above command is segfault-ing systematically on my host. This happens after it prompts "Currently Attached USB Devices:". This seems consistent with the fact that I don't have any issue with VMs that are not configured for using USB passthrough. Adding the --machinereadable option has no effect.

While this is a problem with tools relying on VBoxManage showvminfo for their own VMs lifecycle management, on the hypervisor VirtualBox side of things the VMs are apparently starting correctly and the USB passthrough itself seems to be working if devices are connected after boot. Still VBoxManage showvminfo is segfault-ing at every run.

Currently verified on an Ubuntu 16.04.5 host with latest updates. Same happens with latest VirtualBox 6.0.2.

Here is the segfault context I have collected so far.

VBoxManage[3754]: segfault at 0 ip 000000000045cf0d sp 00007ffe37e1e550 error 4 in VBoxManage[400000+10a000]

Things I tried already, with no noticeable result:

  • upgraded to latest 6.0.2
  • created fresh machines with different (recent) guest OSs and USB passthrough enabled (all fail)
  • configured USB filters for a couple of different devices

Let me know if I can provide more context or how to proceed with further testing.

Change History

comment:1 follow-up: ↓ 2 Changed 10 months ago by socratis

I've been asking users for their "VBoxManage showvminfo" for a looong time (specifically because I want to look at their USB filters), including after 6.0.0/2 was released. Not one has reported a segfault.

Which makes something about your system special. Anything out of the ordinary done to the system, that you can think of? Is this a vanilla installation (highly doubt it)? What's the output of "VBoxManage -version"? Any USB filters, like Wireshark for example?

comment:2 in reply to: ↑ 1 Changed 10 months ago by gizero

This box is definitely not a "fresh" one, but this passthrough used to work for ages with many VirtualBox major release upgrades and VirtualBox itself is installed from official packages.

$ VBoxManage -version 6.0.2r128162

I can reproduce with a single filter (and no global filters) I create like this:

VBoxManage modifyvm dca35b63-bc7d-4828-a4ad-839859452801 --usb on
VBoxManage usbfilter add 0 --target dca35b63-bc7d-4828-a4ad-839859452801 --name cardwriter --vendorid 0x0BDA --productid 0x0151

And here is the relevant VBoxManage showvminfo output (no device connected):

[...]

USB Device Filters:

Index:                       0
Active:                      yes
Name:                        cardwriter
VendorId:                    0bda
ProductId:                   0151
Revision:                    
Manufacturer:                
Product:                     
Remote:                      
Serial Number:               

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>


[...]

...while with corresponding device attached it segfaults right before listing the attached devices:

[...]

USB Device Filters:

Index:                       0
Active:                      yes
Name:                        Arturo
VendorId:                    0bda
ProductId:                   0151
Revision:                    
Manufacturer:                
Product:                     
Remote:                      
Serial Number:               

Available remote USB devices:

<none>

Currently Attached USB Devices:

[1]    18213 segmentation fault (core dumped)  VBoxManage showvminfo dca35b63-bc7d-4828-a4ad-839859452801

Testing on a different box may take me some time, but if it's worth I can try to allocate a slot soon.

comment:3 Changed 10 months ago by Monsoft

I have this same issue with newest VirtualBox 6.0.4. If I attach any USB device to vm I got Segmentation fault.

Example:

$ VBoxManage showvminfo 199b5a00-c284-49c7-90fb-cb87624d546d --machinereadable
name="WinWorkstation"
groups="/"
ostype="Windows 7 (64-bit)"
UUID="199b5a00-c284-49c7-90fb-cb87624d546d"
CfgFile="/storage/virtualbox/WinWorkstation/WinWorkstation.vbox"
SnapFldr="/storage/virtualbox/WinWorkstation/Snapshots"
LogFldr="/storage/virtualbox/WinWorkstation/Logs"
hardwareuuid="199b5a00-c284-49c7-90fb-cb87624d546d"

[...]

Segmentation fault (core dumped)

If I detach usb device all works correctly

comment:4 Changed 10 months ago by pentagonik

Are you able to supply the created core dump by uploading it somewhere so that we can take a look?

comment:6 Changed 10 months ago by pentagonik

Great, thank you! We'll have a look.

comment:7 Changed 10 months ago by pentagonik

@Monsoft Which host is this exactly, e.g. which VBox package (platform) did you use?

comment:8 Changed 10 months ago by Monsoft

I work on Linux Mint 19:

Distributor ID:	LinuxMint
Description:	Linux Mint 19 Tara
Release:	19
Codename:	tara

VBox Version 6.0.4 r128413 (Qt5.9.5) installed from repo:

virtualbox-6.0                             6.0.4-128413~Ubuntu~bionic

Last edited 10 months ago by Monsoft (previous) (diff)

comment:9 Changed 10 months ago by mjv39474

I have exactly the same problem:

# cat /etc/system-release
CentOS Linux release 7.6.1810 (Core)
# yum info VirtualBox-6.0
...
Installed Packages
Name        : VirtualBox-6.0
Arch        : x86_64
Version     : 6.0.4_128413_el7

comment:10 Changed 10 months ago by pentagonik

We found and fix the issue; the fix will be available in the next upcoming maintenance release.

comment:11 Changed 9 months ago by mjv39474

Thanks!

comment:12 follow-up: ↓ 13 Changed 9 months ago by pentagonik

Test build >= 128880 for VirtualBox 6.0 should contain fix -- you can get the latest test builds on the Testbuilds page.

Please let me know if this fixes the issue for you. Thank you!

comment:13 in reply to: ↑ 12 Changed 8 months ago by gizero

Replying to pentagonik:

Test build >= 128880 for VirtualBox 6.0 should contain fix -- you can get the latest test builds on the Testbuilds page.

Please let me know if this fixes the issue for you. Thank you!

Finally got a chance to give the testbuild @ 129045 a run. I confirm the issue is not reproducible anymore! Looking forward for the official 6.0.5. Thanks!

comment:14 Changed 8 months ago by pentagonik

Great to hear, thanks for the feedback! Closing this ticket.

comment:15 Changed 8 months ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:16 Changed 8 months ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:17 Changed 7 months ago by michael

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Summary changed from VBoxManage showvminfo segfault in 6.0.x to VBoxManage showvminfo segfault in 6.0.x -> fixed in releases after 6.0.4

comment:18 Changed 7 months ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use