VirtualBox

Ticket #18318 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Virtualbox leaves multiple services running after shutdown

Reported by: Fochi Owned by:
Component: host support Version: VirtualBox 6.0.2
Keywords: Cc:
Guest type: all Host type: Linux

Description

Bug description and How to reproduce: Linux creates 3 processes when you launch VirtualBox 6.x GUI: VBoxSVC, VBoxXPCOMIPCD and the VirtualBox application.

If you close the VirtualBox application, the process should end (as it occurs with VirtualBox 5.2 and older), but the VirtualBox 6.x process stays running in the background.

Every time you launch the VirtualBox application, a new VirtualBox process is created. All those processes stay running in background after you close each application.

When you reboot your desktop, VirtualBox will automatically launch as many copies of the VirtualBox GUI as you have opened and closed in your last desktop section. And as all of them will be opened again, every passing day you have to close more and more VirtualBox instances.

Affected versions: This bug was introduced in VirtualBox 6.0.0 Host : Linux Fedora 29 last update on 2019/01/16 Desktop: KDE5 Guests : There is no need to launch a Guest machine to see this bug.

I reverted to VirtualBox 5.2 and confirmed that the bug only exists in version 6.0.0 and above.

Change History

comment:1 Changed 2 years ago by Fochi

After some time I noticed that on another Linux machine the bug was not seen, and I had to reinstall VirtualBox 6.0.4 to check for the reasons of the failure in this machine.

It has been proved beyond any doubt that the failure is triggered by accented characters in the name of machine groups.

Because this bug is just a collateral effect of the other bug, I decided to create a bug report for the GUI issues in this ticket: https://www.virtualbox.org/ticket/18392 .

If any developer decides to check this bug, just follow the easy step by step reported there, than read again the first post above and confirm the bug.

comment:2 Changed 2 years ago by Fochi

By the way, there is a small difference between the Linux and Windows behaviour:

On Linux KDE if there are "n" unclosed VirtualBox processes, than when you reboot the host it will automatically launch "n" VirtualBox GUIs.

On Windows, whenever you launch and close a GUI, a new uncleanly closed VirtualBox process is left open exactly like on Linux, however no GUI will be automatically launched on next host boot.

Hope this helps.

comment:3 Changed 2 years ago by janitor

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 2 years ago by Fochi

Dears, how can I know if this bug will get any attention from developers?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use