VirtualBox

Ticket #18282 (closed defect: fixed)

Opened 9 months ago

Last modified 5 months ago

EFI shell not shown when VMSVGA or VBoxSVGA is chosen. No installation is possible. => fixed in svn

Reported by: socratis Owned by:
Component: EFI Version: VirtualBox 6.0.0
Keywords: EFI shell, VMSVGA, VBoxSVGA Cc:
Guest type: all Host type: all

Description

If the Graphics Controller is not set as a VBoxVGA, and a bootable medium is not provided, then the EFI shell never comes up.

On top of that, none of the following ExtraData are honored if VMSVGA is chosen, the resolution comes up with the "default" 640x480 :

<ExtraDataItem name="VBoxInternal2/EfiGopMode" value="3"/>
<ExtraDataItem name="VBoxInternal2/EfiGraphicsResolution" value="1280x1024"/>
<ExtraDataItem name="VBoxInternal2/EfiHorizontalResolution" value="1280"/>
<ExtraDataItem name="VBoxInternal2/EfiVerticalResolution" value="1024"/>

Change History

comment:1 Changed 9 months ago by socratis

UPDATE
Actually it's worse than simply not having the shell showing; no booting happens. I tried a Win10-Oct1809 and an OSX 10.8.5 guests. No booting, no go, no matter the vGPU option, unless it's the old VBoxVGA...

UPDATE 2
I hate that I can't edit my ticket, but if a gentle soul could amend the "No installation is possible." to the end of the ticket description, I'd appreciate it!

Last edited 9 months ago by socratis (previous) (diff)

comment:2 Changed 9 months ago by gombara

  • Summary changed from EFI shell not shown when VMSVGA or VBoxSVGA is chosen. to EFI shell not shown when VMSVGA or VBoxSVGA is chosen. No installation is possible.

comment:3 Changed 9 months ago by socratis

Thanks @gombara!

comment:4 Changed 8 months ago by klaus

The cause is quite simple: as of today there's no graphics driver in the EFI firmware which handles VMSVGA or VBoxSVGA. For VBoxSVGA it should be a limited effort (since it's mostly compatible with VBoxVGA), and for VMSVGA it's more work. All open source, see the EFI firmware directory.

comment:5 Changed 8 months ago by toracat

CC: me

comment:6 Changed 8 months ago by socratis

I understand the part about the EFI and the "age"/maturity of the VBoxSVGA/VMSVGA; they both need some work. I just wanted to have a placeholder so that the developers won't forget. ;)

But mainly so that I can point people to something tangible...

comment:7 Changed 7 months ago by Fake4d

CC: me

comment:8 Changed 7 months ago by rjcuk

CC: me on VirtualBox 6.0.4

comment:9 Changed 7 months ago by klaus

Latest 6.0 Testbuilds should have this issue fixed. Both for VBoxSVGA and VMSVGA. Please confirm, feedback is much appreciated.

comment:10 Changed 7 months ago by socratis

Confirmed as fixed with version 6.0.5 r128870 (Qt5.6.3).

Tested with a Win10-64 (VBoxSVGA), and Ubuntu 18.10 (VMSVGA) guests on an OSX 10.11.6 host.

Thanks @klaus!

comment:11 Changed 7 months ago by klaus

  • Summary changed from EFI shell not shown when VMSVGA or VBoxSVGA is chosen. No installation is possible. to EFI shell not shown when VMSVGA or VBoxSVGA is chosen. No installation is possible. => fixed in svn

comment:12 Changed 7 months ago by Mike Vastola

CC: me

comment:13 Changed 7 months ago by 林博仁(Buo-Ren, Lin)

CC: me

comment:14 Changed 7 months ago by socratis

@ALL

It would be more beneficial if you could give your some feedback with regards to the test builds, instead of simply Cc:ing yourselves to the ticket... ;)

Anything over r128870 would do...

comment:15 Changed 7 months ago by Fake4d

@socratis : You are right :) Had to smile a little bit!

I tried the built 6.0.x revision 128914 on Linux 64bit (Ubuntu 18.04.2) and Windows 10 (1809). Both working for me - your new built seems fine in my setup.

comment:16 Changed 7 months ago by socratis

I'm sure a developer "just got their wings"... :)

Thanks @Fake4d for confirming...

comment:17 Changed 5 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use