VirtualBox

Ticket #18264 (closed defect: fixed)

Opened 6 months ago

Last modified 2 months ago

conflicting desktop files in deb packages -> fixed after (not in) 6.0.0 and 5.2.22

Reported by: syphyr Owned by:
Component: installer Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: other Host type: other

Description

The gnome-software package manager in Ubuntu 18.04 detects conflicting virtualbox desktop files with virtualbox-qt and virtualbox-6.0. It is illegal for different package names to contain the same desktop files. For example:

virtualbox-5.1: /usr/share/applications/virtualbox.desktop

virtualbox-5.2: /usr/share/applications/virtualbox.desktop

virtualbox-6.0: /usr/share/applications/virtualbox.desktop

virtualbox-qt: /usr/share/applications/virtualbox.desktop

The solution would be to rename the common files that are also contained in Ubuntu's repos:

virtualbox-5.1: /usr/share/applications/virtualbox-oracle.desktop

virtualbox-5.2: /usr/share/applications/virtualbox-oracle.desktop

virtualbox-6.0: /usr/share/applications/virtualbox-oracle.desktop

virtualbox-qt: /usr/share/applications/virtualbox.desktop

Notice the "virutalbox-qt" package is from Ubuntu repository and can therefore not be changed.

The message below is from the syslog and it is caused by the conflicting virtualbox.desktop files from Ubuntu's repos and Oracle's repos. Gnome package manager detects that /usr/share/applications/virtualbox.desktop is from Ubuntu's virtualbox-qt package, but that desktop file is being provided by Oracle's virtualbox-6.0 package. So, gnome-software thinks there is an installation problem with the packages because of the installed files that belong to both package names.

Jan 2 20:05:20 testbot gnome-software[2272]: ignoring non-installed app GsApp: [0x7f4670163cf0]#012kind: desktop#012state: available#012quirk: provenance#012id: virtualbox.desktop#012unique-id: system/package/ubuntu-bionic-updates-multiverse/desktop/virtualbox.desktop/*#012scope: system#012bundle-kind: package#012kudos: my-language|has-keywords|popular#012kudo-percentage: 50#012name: VirtualBox#012pixbuf: 0x7f46702beb60#012icon-kind: cached#012icon-pixbuf: 0x7f46702beb60#012icon-name: virtualbox-qt_virtualbox.png#012icon-prefix: /var/lib/app-info/icons/ubuntu-bionic-updates-multiverse#012version: 5.2.18-dfsg-2~ubuntu18.04.1#012summary: Run several virtual systems on a single host computer#012description: VirtualBox is a free x86 virtualization solution allowing a wide range of x86 operating systems such as Windows, DOS, BSD or Linux to run on a Linux system.#012#012This package provides the Qt based graphical user interface for VirtualBox.#012source-00: virtualbox-qt#012source-id-00: virtualbox-qt;5.2.18-dfsg-2~ubuntu18.04.1;amd64;ubuntu-bionic-updates-multiverse#012url{homepage}:  https://www.virtualbox.org#012license: unknown#012license-is-free: no#012management-plugin: packagekit#012origin: ubuntu-bionic-updates-multiverse#012origin-appstream: ubuntu-bionic-updates-multiverse#012rating: 88#012review-rating: [0:0]#012review-rating: [1:23]#012review-rating: [2:3]#012review-rating: [3:29]#012review-rating: [4:65]#012review-rating: [5:279]#012reviews: 0#012provides: 0#012install-date: 1546387200#012size-installed: unknowable#012size-download: 8.6 MB#012history: */*/*/generic/virtualbox.desktop/*#012category: Emulator#012category: System#012category: Utility#012keyword: virtualization#012{GnomeSoftware::Creator}: appstream#012{appstream::source-file}: /usr/share/applications/virtualbox.desktop

Change History

comment:1 follow-up: ↓ 2 Changed 6 months ago by socratis

You're not supposed to have both the official VirtualBox and the fork from (name your distro), they're conflicting in more than one ways!

You should completely uninstall whatever you have and then install the official one from the Linux Downloads section. You can even add VirtualBox as a repository, so you could use your traditional install/upgrade/uninstall tools.

comment:2 in reply to: ↑ 1 Changed 6 months ago by syphyr

Replying to socratis:

You're not supposed to have both the official VirtualBox and the fork from (name your distro), they're conflicting in more than one ways!

You should completely uninstall whatever you have and then install the official one from the Linux Downloads section. You can even add VirtualBox as a repository, so you could use your traditional install/upgrade/uninstall tools.

I never had both versions of virtialbox installed. I only have oracle's version installed. This is just an issue with the gnome-software package thinking that desktop file belongs to Ubuntu's virtualbox package because all of Ubuntu's desktop file associations are kept in a database for the package installer, whether they are installed or not.

If I change the name of the desktop file provided by Oracle's installer, then the gnome-software message goes away.

To test the issue, I manually changed the desktop filename to virtualbox-oracle.desktop and now syslog says this:

Jan 2 21:22:48 droid gnome-software[2277]: Failed to find one package for virtualbox-oracle.desktop, /usr/share/applications/virtualbox-oracle.desktop, [0]

But this message above would go away if I didn't have to manually change the desktop filename.

comment:3 Changed 6 months ago by syphyr

I suppose you could argue that the problem is with the gnome-software application because it is not detecting virtualbox.desktop is being provided by Oracle's package. I don't think there are any other examples of two different package names (ie; virtualbox-6.0 and virtualbox-qt) providing the same desktop file. The easiest solution would just be to change the desktop filename to something that doesn't conflict with Ubuntu's package. I have already added Oracle's virtualbox as a repo and installed it properly with apt-get.

comment:4 Changed 5 months ago by michael

  • Summary changed from conflicting desktop files in deb packages to conflicting desktop files in deb packages -> fixed after (not in) 6.0.0 and 5.2.22

The Ubuntu/Debian package maintainer suggested that we add a Conflicts entry against virtualbox-qt, so I will try that for future releases.

comment:5 Changed 2 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use