VirtualBox

Ticket #18263 (closed defect: fixed)

Opened 9 months ago

Last modified 5 months ago

Restoring 32bit Windows7 VM Saved State Fails => fixed in SVN/next maintenance

Reported by: morr_rva Owned by:
Component: other Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

VM boots cleanly, and creates snapshot without problem. When restoring VM from a saved state snapshot, it will always fail with the following:

Failed to load unit 'lsilogicscsi' (VERR_SSM_LOADED_TOO_LITTLE).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Guest Additions are current. I have recreated snapshot without any effect on the problem. This worked correctly with the same VM under 5.2.22 and before.

Attachments

Windows7-2019-01-02-10-16-08.log Download (168.7 KB) - added by morr_rva 9 months ago.
Logs.zip Download (161.7 KB) - added by MmnOnZeNet 9 months ago.
bitnami-modx-2019-01-18-08-58-56.zip Download (27.5 KB) - added by wallacio 8 months ago.
Debian 9 guest resuming from saved state

Change History

Changed 9 months ago by morr_rva

comment:1 follow-up: ↓ 2 Changed 9 months ago by socratis

  1. Did you post a similar question recently in the forums?
  1. Can you try to switch from SCSI:LsiLogic to SATA:AHCI? Does the "Restore snapshot" error go away?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 9 months ago by morr_rva

Replying to socratis:

  1. Did you post a similar question recently in the forums?
  1. Can you try to switch from SCSI:LsiLogic to SATA:AHCI? Does the "Restore snapshot" error go away?

No, I haven't posted a question. I searched for other issues like this without success, though.

If I switch controllers, the VM will not boot at all. I no longer have installation media for such an old OS, and the drivers for that controller are not installed.

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 6 Changed 9 months ago by socratis

Replying to morr_rva:

If I switch controllers, the VM will not boot at all. I no longer have installation media for such an old OS, and the drivers for that controller are not installed.

Windows 7 an old OS? You haven't tried a DOS VM, right? :)

And you shouldn't need to replace the controller directly and try to boot from it:

  • Add a 2nd controller, the SATA:AHCI one. Win7 has built-in drivers, it should find it and install the drivers, no "external" or "installation" media required.
  • Now remove the disk (VDI) from the SCSI controller and add it to the SATA one.
  • Boot the VM to make sure that everything is in order.
  • Remove the SCSI controller altogether.

BACKUP FIRST!!!

Changed 9 months ago by MmnOnZeNet

comment:4 Changed 9 months ago by MmnOnZeNet

I got the same issue with Host windows 10 64 bits and guest Oracle Enterprise Linux 7 64 bits. I attach the logs

comment:5 Changed 9 months ago by socratis

@MmnOnZeNet

00:00:02.510433 [/Devices/lsilogicscsi/0/Config/] (level 4)
00:00:02.510434   Bootable <integer> = 0x0000000000000001 (1)

Yeah, you have what seems to be the same SCSI:LsiLogic issue as well...

comment:6 in reply to: ↑ 3 Changed 9 months ago by morr_rva

Replying to socratis:

Replying to morr_rva:

If I switch controllers, the VM will not boot at all. I no longer have installation media for such an old OS, and the drivers for that controller are not installed.

Windows 7 an old OS? You haven't tried a DOS VM, right? :)

And you shouldn't need to replace the controller directly and try to boot from it:

  • Add a 2nd controller, the SATA:AHCI one. Win7 has built-in drivers, it should find it and install the drivers, no "external" or "installation" media required.
  • Now remove the disk (VDI) from the SCSI controller and add it to the SATA one.
  • Boot the VM to make sure that everything is in order.
  • Remove the SCSI controller altogether.

BACKUP FIRST!!!

Thank you. This seems to have resolved the issue.

comment:7 Changed 9 months ago by socratis

@morr_rva
Not really, it's a workaround to get you started. The ticket is still valid and it has to be addressed.

There are two workarounds it seems:

  • Switch to SATA:AHCI.
  • Don't use saved states... ;)

Changed 8 months ago by wallacio

Debian 9 guest resuming from saved state

comment:8 Changed 8 months ago by wallacio

Same issue, different host/guest. Attaching logs in case it's any help with debugging.

comment:9 Changed 8 months ago by andronat

Same issue for me when I'm using Vagrant under Host: macos 10.14.3 and guest: ubuntu 18.04.1.

➜  srg-website git:(master) ✗ vagrant up && vagrant ssh
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'ubuntu/bionic64' version '20181114.1.0' is up to date...
==> default: Resuming suspended VM...
==> default: Booting VM...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "c3bdd69a-c569-4779-bdeb-82cb9a5054e3", "--type", "headless"]

Stderr: VBoxManage: error: Failed to load unit 'lsilogicscsi' (VERR_SSM_LOADED_TOO_LITTLE)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ConsoleWrap, interface IConsole

comment:10 Changed 8 months ago by mzb

Same issue for me after suspend / restore - also using Vagrant: VirtualBox: 6.0.2 host: Windows 10 guest: Ubuntu 16.04

Failed to open a session for the virtual machine web3_default_1548545169711_21792.

Failed to load unit 'lsilogicscsi' (VERR_SSM_LOADED_TOO_LITTLE).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Last edited 8 months ago by mzb (previous) (diff)

comment:11 Changed 8 months ago by msys

I'm also affected but both guest and host are Windows 7 64-bit (so no Linux is involved).

Also, the same problem occurs with SAS controller (the same error but with 'lsilogicsas' instead).

Relevant forum post:  https://forums.virtualbox.org/viewtopic.php?f=6&t=91520

comment:12 Changed 8 months ago by grmblfrz

Same problem here with SAS controller (Arch Linux host, Windows 7 guest). Restore does no longer work. VirtualBox 6.0.4 with matching guest additions.

Last edited 8 months ago by grmblfrz (previous) (diff)

comment:13 follow-up: ↓ 14 Changed 7 months ago by aeichner

  • Summary changed from Restoring 32bit Windows7 VM Saved State Fails to Restoring 32bit Windows7 VM Saved State Fails => fixed in SVN/next maintenance

Confirmed, will be fixed in the next maintenance release. Thanks for the reports!

comment:14 in reply to: ↑ 13 Changed 6 months ago by zephyrus

Replying to aeichner:

Confirmed, will be fixed in the next maintenance release. Thanks for the reports!

I got hit with the same issues twice in a row. I am using VBox 6.0.4 r128413 for a few weeks no.q

I am using windows 64-bit host and a 64-bit linux Debian GNU/Linux guest. I was requsted to reboot the windows PC once to install the latest update of Norton Internet security and then, today, for Windows update. I got hit with the same error first while I performed Norton update, and I thought I would look into the matter when I forgot the issue and let it reboot to finish the windows update.

An early fix would be very much appreciated. I had a reason to choose SCSI, but I have forgotten exactly what. I am going to bite the bullet and switch to SATA AHCI for now.

Last edited 6 months ago by zephyrus (previous) (diff)

comment:15 Changed 6 months ago by aeichner

Please try the latest 6.0 testbuild from here. It should contain the fix.

comment:16 Changed 5 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use